# CVE-2026-41258: OpenMRS: Stored Velocity SSTI to RCE via ConceptReferenceRange

> A user with Manage Concepts privilege can execute arbitrary code via stored Velocity templates in concept reference ranges.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-xj4f-8jjg-vx4q

## What is CVE-2026-41258?

CVE-2026-41258 is a critical code injection vulnerability in openmrs-core, published on 15 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenMRS is an open source electronic medical record system platform. From 2.7.0 to before 2.7.9 and 2.8.6, the ConceptReferenceRangeUtility.evaluateCriteria() method in OpenMRS Core evaluates database-stored criteria strings as Apache Velocity templates without any sandbox configuration. The VelocityEngine is initialized with only logging properties and noSecureUberspector, leaving the default UberspectImpl in place, which allows unrestricted Java reflection through template expressions. A user with the Manage Concepts privilege can store a malicious Velocity template expression in a concept's reference range criteria field. This payload is then executed automatically whenever a user or API call validates an observation against the affected concept. The Velocity context exposes $patient (the Person / Patient object), $obs (the Obs object), and $fn (the ConceptReferenceRangeUtility instance with access to the full OpenMRS service layer). This vulnerability is fixed in 2.7.9 and 2.8.6.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-41258?

4 open source packages ship an affected version, including org.openmrs.api:openmrs-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openmrs.api:openmrs-api` | Maven | From 2.7.0 | 2.7.9 |
| `org.openmrs.api:openmrs-api` | Maven | From 2.7.0 | 2.7.9 |
| `org.openmrs.api:openmrs-api` | Maven | From 2.8.0 | 2.8.6 |
| `org.openmrs.api:openmrs-api` | Maven | From 2.8.0 | 2.8.6 |

## How do I fix CVE-2026-41258?

Upgrade org.openmrs.api:openmrs-api to a fixed version for your release line: 2.7.9 or 2.8.6.

## Is CVE-2026-41258 being exploited?

There is no known exploitation of CVE-2026-41258 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41258 and fix it if it is affected.

What it is: CVE-2026-41258 is a critical code injection vulnerability in openmrs-core, published on 15 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41258 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openmrs.api:openmrs-api (Maven): affected from 2.7.0; fixed in 2.7.9
- org.openmrs.api:openmrs-api (Maven): affected from 2.7.0; fixed in 2.7.9
- org.openmrs.api:openmrs-api (Maven): affected from 2.8.0; fixed in 2.8.6
- org.openmrs.api:openmrs-api (Maven): affected from 2.8.0; fixed in 2.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41258/ (Markdown: https://insights.sbomify.com/CVE-2026-41258/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41258
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41258
- OSV: https://osv.dev/vulnerability/CVE-2026-41258

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41258/
Summaries are generated and may contain mistakes; the official description above is the record.
