CVE-2026-41273 Flowise: Unauthenticated OAuth 2.0 Access Token Disclosure via Public Chatflow
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-41273?
CVE-2026-41273 is a high-severity vulnerability in Flowiseai Flowise, published on 23 Apr 2026.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise contains an authentication bypass vulnerability that allows an unauthenticated attacker to obtain OAuth 2.0 access tokens associated with a public chatflow. By accessing a public chatflow configuration endpoint, an attacker can retrieve internal workflow data, including OAuth credential identifiers, which can then be used to refresh and obtain valid OAuth 2.0 access tokens without authentication. This vulnerability is fixed in 3.1.0.
Weakness: CWE-306
Which versions are affected by CVE-2026-41273?
2 open source packages ship an affected version, including flowise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise npm | All versions | 3.1.0 |
flowise npm | All versions | 3.1.0 |
Products include Flowiseai Flowise.
How do I fix CVE-2026-41273?
Upgrade flowise to 3.1.0 or later.
Is CVE-2026-41273 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41273 exists.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-6f7g-v4pp-r667.