{"answers":{"affected":"4 open source packages ship an affected version, including flowise and flowise-components. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41274 exists.","fix":"Upgrade flowise to 3.1.0 or later.","what":"CVE-2026-41274 is a critical code injection vulnerability in Flowiseai Flowise, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41274 and fix it if it is affected.\n\nWhat it is: CVE-2026-41274 is a critical code injection vulnerability in Flowiseai Flowise, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41274 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 3.1.0\n- flowise (npm): affected all versions; fixed in 3.1.0\n- flowise-components (npm): affected all versions; fixed in 3.1.0\n- flowise-components (npm): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41274/ (Markdown: https://insights.sbomify.com/CVE-2026-41274/index.md)","id":"CVE-2026-41274","markdown":"https://insights.sbomify.com/CVE-2026-41274/index.md","name":"CVE-2026-41274","record":{"aliases":["GHSA-28g4-38q8-3cwc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM flow builder","requires_auth":"none","summary":"Attackers can inject arbitrary Cypher commands into the GraphCypherQAChain node to read, modify, or delete data in the underlying Neo4j database.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-943","name":"Improper Neutralization of Special Elements in Data Query Logic"}],"description":"Flowise is a drag \u0026 drop user interface to build a customized large language model flow. Prior to 3.1.0, the GraphCypherQAChain node forwards user-provided input directly into the Cypher query execution pipeline without proper sanitization. An attacker can inject arbitrary Cypher commands that are executed on the underlying Neo4j database, enabling data exfiltration, modification, or deletion. This vulnerability is fixed in 3.1.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flowise: Cypher Injection in GraphCypherQAChain","id":"CVE-2026-41274","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"code_injection","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"Flowise: Password Reset Link Sent Over Unsecured HTTP","id":"CVE-2026-41275"},"packages":[{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-28g4-38q8-3cwc"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-28g4-38q8-3cwc"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise-components","purl":null,"source":"GHSA-28g4-38q8-3cwc"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise-components","purl":"pkg:npm/flowise-components","source":"GHSA-28g4-38q8-3cwc"}],"prev":{"headline":"Flowise: Unauthenticated OAuth 2.0 Access Token Disclosure via Public Chatflow","id":"CVE-2026-41273"},"products":["Flowise","flowise-components"],"published":"2026-04-23","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-24","vendors":["FlowiseAI"]},"summary":"Attackers can inject arbitrary Cypher commands into the GraphCypherQAChain node to read, modify, or delete data in the underlying Neo4j database.","url":"https://insights.sbomify.com/CVE-2026-41274/"}