# CVE-2026-41277: Flowise: Mass Assignment in DocumentStore Create Endpoint Leads to Cross-Workspace Object Takeover (IDOR)

> Authenticated users can overwrite DocumentStore objects in other workspaces via mass assignment, leading to cross-tenant data modification.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 25 Apr 2026
- **Also known as:** GHSA-3prp-9gf7-4rxx

## What is CVE-2026-41277?

CVE-2026-41277 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Mass Assignment vulnerability in the DocumentStore creation endpoint allows authenticated users to control the primary key (id) and internal state fields of DocumentStore entities. Because the service uses repository.save() with a client-supplied primary key, the POST create endpoint behaves as an implicit UPSERT operation. This enables overwriting existing DocumentStore objects. In multi-workspace or multi-tenant deployments, this can lead to cross-workspace object takeover and broken object-level authorization (IDOR), allowing an attacker to reassign or modify DocumentStore objects belonging to other workspaces. This vulnerability is fixed in 3.1.0.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-41277?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.0 |
| `flowise` | npm | All versions | 3.1.0 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-41277?

Upgrade flowise to 3.1.0 or later.

## Is CVE-2026-41277 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41277 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41277 and fix it if it is affected.

What it is: CVE-2026-41277 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41277 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.0
- flowise (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41277/ (Markdown: https://insights.sbomify.com/CVE-2026-41277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41277
- OSV: https://osv.dev/vulnerability/CVE-2026-41277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41277/
Summaries are generated and may contain mistakes; the official description above is the record.
