CVE-2026-41278 Flowise: Public chatflow endpoints return unsanitized flowData including plaintext API keys, passwords, and credential IDs
Attackers can retrieve plaintext API keys and passwords from public chatflow endpoints due to missing data sanitization in Flowise.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41278?
CVE-2026-41278 is a high-severity vulnerability in Flowiseai Flowise, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the GET /api/v1/public-chatflows/:id endpoint returns the full chatflow object without sanitization for public chatflows. Docker validation revealed this is worse than initially assessed: the sanitizeFlowDataForPublicEndpoint function does NOT exist in the released v3.0.13 Docker image. Both public-chatflows AND public-chatbotConfig return completely raw flowData including credential IDs, plaintext API keys, and password-type fields. This vulnerability is fixed in 3.1.0.
Weakness: CWE-200
Which versions are affected by CVE-2026-41278?
2 open source packages ship an affected version, including flowise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise npm | All versions | 3.1.0 |
flowise npm | All versions | 3.1.0 |
Products include Flowiseai Flowise.
How do I fix CVE-2026-41278?
Upgrade flowise to 3.1.0 or later.
Is CVE-2026-41278 being exploited?
There is no known exploitation of CVE-2026-41278 in the wild and no public exploit code.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-w47f-j8rh-wx87.