{"answers":{"affected":"2 open source packages ship an affected version, including flowise. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-41279 in the wild and no public exploit code.","fix":"Upgrade flowise to 3.1.0 or later.","what":"CVE-2026-41279 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41279 and fix it if it is affected.\n\nWhat it is: CVE-2026-41279 is a high-severity missing authorization vulnerability in Flowiseai Flowise, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-41279 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 3.1.0\n- flowise (npm): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41279/ (Markdown: https://insights.sbomify.com/CVE-2026-41279/index.md)","id":"CVE-2026-41279","markdown":"https://insights.sbomify.com/CVE-2026-41279/index.md","name":"CVE-2026-41279","record":{"aliases":["GHSA-5fw2-mwhh-9947"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","other"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM flow builder","requires_auth":"none","summary":"Unauthenticated users can abuse stored API credentials via the text-to-speech endpoint, leading to unauthorized API usage and potential financial loss.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"Flowise is a drag \u0026 drop user interface to build a customized large language model flow. Prior to 3.1.0, the text-to-speech generation endpoint (POST /api/v1/text-to-speech/generate) is whitelisted (no auth) and accepts a credentialId directly in the request body. When called without a chatflowId, the endpoint uses the provided credentialId to decrypt the stored credential (e.g., OpenAI or ElevenLabs API key) and generate speech. This vulnerability is fixed in 3.1.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Flowise: Unauthenticated TTS endpoint accepts arbitrary credential IDs — enables API credit abuse via stored credentials","id":"CVE-2026-41279","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Apache DolphinScheduler: Incorrect Authorization vulnerability allows users with system login privileges to delete task definitions in unauthorized projects","id":"CVE-2026-41280"},"packages":[{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-5fw2-mwhh-9947"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-5fw2-mwhh-9947"}],"prev":{"headline":"Flowise: Public chatflow endpoints return unsanitized flowData including plaintext API keys, passwords, and credential IDs","id":"CVE-2026-41278"},"products":["Flowise"],"published":"2026-04-23","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-23","vendors":["FlowiseAI"]},"summary":"Unauthenticated users can abuse stored API credentials via the text-to-speech endpoint, leading to unauthorized API usage and potential financial loss.","url":"https://insights.sbomify.com/CVE-2026-41279/"}