# CVE-2026-41283: OpenStack Mistral allows Arbitrary Remote Code Execution when the API is exposed

> Attackers can execute arbitrary code via exposed API endpoints in OpenStack Mistral, leading to credential exfiltration.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2026
- **Updated:** 15 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-41283, GHSA-9hfw-w3f4-c4p8, PYSEC-2026-3486, UBUNTU-CVE-2026-41283

## What is CVE-2026-41283?

CVE-2026-41283 is a critical code injection vulnerability in OpenStack Mistral, published on 4 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Mistral through 22.0.0 allows Arbitrary Remote Code Execution when the API is exposed. There are endpoints that allow code execution, which can lead to exfiltration of service credentials.

Weakness: CWE-749 (Exposed Dangerous Method or Function), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-41283?

6 open source packages ship an affected version, including mistral.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mistral` | PyPI | All versions | None |
| `mistral` | PyPI | All versions | None |
| `mistral` | PyPI | All versions | None |
| `mistral` | PyPI | From 20.0.0 | 20.1.1 |
| `mistral` | PyPI | From 20.0.0 | 20.1.1 |
| `mistral` | PyPI | From 20.0.0 | 20.1.1 |

## How do I fix CVE-2026-41283?

Upgrade mistral to 20.1.1 or later.

## Is CVE-2026-41283 being exploited?

There is no known exploitation of CVE-2026-41283 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41283 and fix it if it is affected.

What it is: CVE-2026-41283 is a critical code injection vulnerability in OpenStack Mistral, published on 4 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41283 in the wild and no public exploit code.

Affected packages and fixed versions:
- mistral (PyPI): affected all versions; no fix listed
- mistral (PyPI): affected all versions; no fix listed
- mistral (PyPI): affected all versions; no fix listed
- mistral (PyPI): affected from 20.0.0; fixed in 20.1.1
- mistral (PyPI): affected from 20.0.0; fixed in 20.1.1
- mistral (PyPI): affected from 20.0.0; fixed in 20.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41283/ (Markdown: https://insights.sbomify.com/CVE-2026-41283/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41283
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41283
- OSV: https://osv.dev/vulnerability/CVE-2026-41283

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41283/
Summaries are generated and may contain mistakes; the official description above is the record.
