CVE-2026-41284 Apache Tomcat: Unbounded read in WebDAV LOCK and PROPFIND handling
Attackers can cause denial of service in Apache Tomcat via unbounded resource allocation in WebDAV LOCK and PROPFIND requests.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41284?
CVE-2026-41284 is a high-severity denial of service vulnerability in Apache Tomcat, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117. Older, unsupported versions may also be affected.
Users are recommended to upgrade to version [FIXED_VERSION], which fixes the issue.
Weakness: CWE-770
Which versions are affected by CVE-2026-41284?
19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | All versions | 9.0.118 |
org.apache.tomcat.embed:tomcat-embed-core Maven | All versions | 9.0.118 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.22 |
13 more packages
tomcat Bitnami | From 10.0.0 | 10.1.55, 11.0.22, 9.0.118 |
org.apache.tomcat:tomcat Maven | All versions | 9.0.118 |
org.apache.tomcat:tomcat Maven | All versions | 9.0.118 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat:tomcat-catalina Maven | All versions | 9.0.118 |
org.apache.tomcat:tomcat-catalina Maven | All versions | 9.0.118 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat-catalina Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat:tomcat-catalina Maven | From 11.0.0-M1 | 11.0.22 |
Products include Apache Tomcat.
How do I fix CVE-2026-41284?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 9.0.118, 10.1.55 or 11.0.22.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-41284 being exploited?
There is no known exploitation of CVE-2026-41284 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-41284, CLEANSTART-2026-CB76270, CLEANSTART-2026-MV28193, CLSA-2026-1779366970, CLSA-2026-1779377901, DEBIAN-CVE-2026-41284 and 4 more.