CVE-2026-41293 Apache Tomcat: HTTP/2 request headers not validated
Apache Tomcat fails to validate HTTP/2 request headers, potentially allowing malformed requests to bypass security checks or cause unexpected behavior.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41293?
CVE-2026-41293 is a critical vulnerability in Apache Tomcat, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Input Validation vulnerability in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 10.0.0-M1 through 10.0.27. Older, end of support versions may also be affected.
Users are recommended to upgrade to version [FIXED_VERSION], which fixes the issue.
Weakness: CWE-20
Which versions are affected by CVE-2026-41293?
19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 | 9.0.118 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 | 9.0.118 |
13 more packages
tomcat Bitnami | From 10.0.0 | 10.1.55, 11.0.22, 9.0.118 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat:tomcat Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat:tomcat Maven | From 8.5.0 | 9.0.118 |
org.apache.tomcat:tomcat Maven | From 8.5.0 | 9.0.118 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.0-M1 | 10.1.55 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M1 | 11.0.22 |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 | 9.0.118 |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 | 9.0.118 |
Products include Apache Tomcat.
How do I fix CVE-2026-41293?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.55, 11.0.22 or 9.0.118.
Is CVE-2026-41293 being exploited?
There is no known exploitation of CVE-2026-41293 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-41293, CLEANSTART-2026-NC17468, CLEANSTART-2026-WT20984, CLSA-2026-1780650326, CLSA-2026-1787058472, DEBIAN-CVE-2026-41293 and 12 more.