# CVE-2026-41293: Apache Tomcat: HTTP/2 request headers not validated

> Apache Tomcat fails to validate HTTP/2 request headers, potentially allowing malformed requests to bypass security checks or cause unexpected behavior.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 17 Sep 2026
- **Also known as:** BIT-tomcat-2026-41293, CLEANSTART-2026-NC17468, CLEANSTART-2026-WT20984, CLSA-2026-1780650326, CLSA-2026-1787058472, DEBIAN-CVE-2026-41293, GHSA-r29c-68gh-xp6x, MINI-222c-wc68-4gxc, MINI-75c5-xpmc-9rf5, MINI-cxhf-q33p-qwcp, MINI-fp64-mhfv-c4v7, MINI-h28w-hf8j-8hg3, MINI-jpxw-965w-642g, MINI-r3jm-hpv5-gc73, MINI-rqp9-8q59-r25p, MINI-w9h8-5vcr-rwx8, ROOT-APP-MAVEN-CVE-2026-41293, UBUNTU-CVE-2026-41293

## What is CVE-2026-41293?

CVE-2026-41293 is a critical vulnerability in Apache Tomcat, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 10.0.0-M1 through 10.0.27.
Older, end of support versions may also be affected.

Users are recommended to upgrade to version [FIXED_VERSION], which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-41293?

19 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.22 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M1 | 11.0.22 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 | 9.0.118 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 | 9.0.118 |
| `tomcat` | Bitnami | From 10.0.0 | 10.1.55, 11.0.22, 9.0.118 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat:tomcat` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.22 |
| `org.apache.tomcat:tomcat` | Maven | From 11.0.0-M1 | 11.0.22 |
| `org.apache.tomcat:tomcat` | Maven | From 8.5.0 | 9.0.118 |
| `org.apache.tomcat:tomcat` | Maven | From 8.5.0 | 9.0.118 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.0-M1 | 10.1.55 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M1 | 11.0.22 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M1 | 11.0.22 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.0 | 9.0.118 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.0 | 9.0.118 |

Products: Apache Tomcat.

## How do I fix CVE-2026-41293?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.55, 11.0.22 or 9.0.118.

## Is CVE-2026-41293 being exploited?

There is no known exploitation of CVE-2026-41293 in the wild and no public exploit code.

Public exploit code:

- 查出 Spring Boot 内嵌 Tomcat 的真实版本(pom 里没有),并对每条 2026 年 CVE 同时给出 ASF 官方评级与 GitHub 评级、触发条件、以及这条会不会进 Dependabot 告警 CVE-2026-41293 (github_poc): https://github.com/xiaoqiMikko/tomcat-check

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41293 and fix it if it is affected.

What it is: CVE-2026-41293 is a critical vulnerability in Apache Tomcat, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41293 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.55
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.0-M1; fixed in 10.1.55
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.22
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M1; fixed in 11.0.22
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0; fixed in 9.0.118
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0; fixed in 9.0.118
- tomcat (Bitnami): affected from 10.0.0; fixed in 10.1.55, 11.0.22, 9.0.118
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.55
- org.apache.tomcat:tomcat (Maven): affected from 10.1.0-M1; fixed in 10.1.55
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.22
- org.apache.tomcat:tomcat (Maven): affected from 11.0.0-M1; fixed in 11.0.22
- org.apache.tomcat:tomcat (Maven): affected from 8.5.0; fixed in 9.0.118

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41293/ (Markdown: https://insights.sbomify.com/CVE-2026-41293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41293
- OSV: https://osv.dev/vulnerability/CVE-2026-41293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41293/
Summaries are generated and may contain mistakes; the official description above is the record.
