# CVE-2026-41294: OpenClaw < 2026.3.28 - Environment Variable Injection via CWD .env File

> Attackers can inject environment variables via a malicious .env file to override security settings and potentially execute code during OpenClaw startup.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** GHSA-8rh7-6779-cjqq, MINI-7mxx-9jc2-5529

## What is CVE-2026-41294?

CVE-2026-41294 is a high-severity vulnerability in Openclaw Openclaw, published on 20 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenClaw before 2026.3.28 loads the current working directory .env file before trusted state-dir configuration, allowing environment variable injection. Attackers can place a malicious .env file in a repository or workspace to override runtime configuration and security-sensitive environment settings during OpenClaw startup.

Weakness: CWE-15 (External Control of System or Configuration Setting)

## Which versions are affected by CVE-2026-41294?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.3.28 |
| `openclaw` | npm | All versions | 2026.3.28 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-41294?

Upgrade openclaw to 2026.3.28 or later.

## Is CVE-2026-41294 being exploited?

There is no known exploitation of CVE-2026-41294 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41294 and fix it if it is affected.

What it is: CVE-2026-41294 is a high-severity vulnerability in Openclaw Openclaw, published on 20 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41294 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.3.28
- openclaw (npm): affected all versions; fixed in 2026.3.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41294/ (Markdown: https://insights.sbomify.com/CVE-2026-41294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41294
- OSV: https://osv.dev/vulnerability/CVE-2026-41294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41294/
Summaries are generated and may contain mistakes; the official description above is the record.
