CVE-2026-41300 OpenClaw < 2026.3.31 - Preservation of Attacker-Discovered Endpoints in Remote Onboarding
Attackers can route gateway credentials to malicious endpoints by preserving discovered URLs in remote onboarding flows, requiring operator acceptance.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-41300?
CVE-2026-41300 is a medium-severity vulnerability in Openclaw Openclaw, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
OpenClaw before 2026.3.31 contains a trust-decline vulnerability that preserves attacker-discovered endpoints in remote onboarding flows. Attackers can route gateway credentials to malicious endpoints by having their discovered URL survive the trust decline process into manual prompts requiring operator acceptance.
Weakness: CWE-372
Which versions are affected by CVE-2026-41300?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.31 |
openclaw npm | All versions | 2026.3.31 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-41300?
Upgrade openclaw to 2026.3.31 or later.
Is CVE-2026-41300 being exploited?
There is no known exploitation of CVE-2026-41300 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-9f4w-67g7-mqwv, MINI-gm94-v3hw-q6jg.