{"answers":{"affected":"2 open source packages ship an affected version, including postcss.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41305 exists.","fix":"Upgrade postcss to 8.5.10 or later.","what":"CVE-2026-41305 is a medium-severity cross-site scripting vulnerability in postcss, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-41305 and fix it if it is affected.\n\nWhat it is: CVE-2026-41305 is a medium-severity cross-site scripting vulnerability in postcss, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41305 exists.\n\nAffected packages and fixed versions:\n- postcss (npm): affected all versions; fixed in 8.5.10\n- postcss (npm): affected all versions; fixed in 8.5.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41305/ (Markdown: https://insights.sbomify.com/CVE-2026-41305/index.md)","id":"CVE-2026-41305","markdown":"https://insights.sbomify.com/CVE-2026-41305/index.md","name":"CVE-2026-41305","record":{"aliases":["CLEANSTART-2026-DB71224","CLSA-2026-1779065184","CLSA-2026-1779065191","CLSA-2026-1779065192","CLSA-2026-1783991047","CLSA-2026-1783991051","CLSA-2026-1791806458","CLSA-2026-1791806570","CLSA-2026-1792160960","CLSA-2026-1792161450","CLSA-2026-1792161451","CLSA-2026-1792161590","CLSA-2026-1792161591","CLSA-2026-1792161812","CLSA-2026-1792161813","CLSA-2026-1792161926","CLSA-2026-1793099909","DEBIAN-CVE-2026-41305","GHSA-qx2v-qp2m-jg93","MINI-3r56-556h-7jf7","MINI-5pv3-7jqj-52mq","MINI-62h8-7mgp-qhxg","MINI-942h-5r63-9rgm","MINI-f38g-652c-2v6c","MINI-hrxw-mwjr-cj3x","MINI-j7q7-5hgw-8jvj","MINI-mw2w-46fq-f8c4","MINI-q7jg-3398-7644","MINI-x7h4-7hp2-32pj","ROOT-APP-NPM-CVE-2026-41305","UBUNTU-CVE-2026-41305"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostCSS library","requires_auth":"none","summary":"PostCSS fails to escape closing style tags, allowing attackers to inject scripts when user CSS is embedded in HTML.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"PostCSS takes a CSS file and provides an API to analyze and modify its rules by transforming the rules into an Abstract Syntax Tree. Versions prior to 8.5.10 do not escape `\u003c/style\u003e` sequences when stringifying CSS ASTs. When user-submitted CSS is parsed and re-stringified for embedding in HTML `\u003cstyle\u003e` tags, `\u003c/style\u003e` in CSS values breaks out of the style context, enabling XSS. Version 8.5.10 fixes the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PostCSS has XSS via Unescaped \u003c/style\u003e in its CSS Stringify Output","id":"CVE-2026-41305","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Password Pusher: JSON API `/p.json` file upload alias bypasses file-push authentication","id":"CVE-2026-41308"},"packages":[{"ecosystem":"npm","fixed":["8.5.10"],"introduced":["0"],"last_affected":[],"package":"postcss","purl":null,"source":"GHSA-qx2v-qp2m-jg93"},{"ecosystem":"npm","fixed":["8.5.10"],"introduced":["0"],"last_affected":[],"package":"postcss","purl":"pkg:npm/postcss","source":"GHSA-qx2v-qp2m-jg93"}],"prev":{"headline":"WWBN AVideo vulnerable to RCE caused by clonesite plugin","id":"CVE-2026-41304"},"products":["postcss"],"published":"2026-04-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-24","vendors":["postcss"]},"summary":"PostCSS fails to escape closing style tags, allowing attackers to inject scripts when user CSS is embedded in HTML.","url":"https://insights.sbomify.com/CVE-2026-41305/"}