# CVE-2026-41308: Password Pusher: JSON API `/p.json` file upload alias bypasses file-push authentication

> Unauthenticated attackers can create file pushes via JSON API, bypassing authentication controls in Password Pusher.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-qfh8-f79c-x86c

## What is CVE-2026-41308?

CVE-2026-41308 is a medium-severity authentication bypass vulnerability in pglombardo PasswordPusher, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Password Pusher is an open source application to communicate sensitive information over the web. Prior to versions 1.69.3 and 2.4.2, a security issue in OSS PasswordPusher allowed unauthenticated creation of file-type pushes through a generic JSON API create path under certain configurations. This could bypass the intended authentication boundary for file push creation. This issue has been patched in versions 1.69.3 and 2.4.2.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2026-41308?

It affects 1 product.


Products: Apnotic Password Pusher.

## How do I fix CVE-2026-41308?

No fix has been published for CVE-2026-41308 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41308 being exploited?

There is no known exploitation of CVE-2026-41308 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41308 and fix it if it is affected.

What it is: CVE-2026-41308 is a medium-severity authentication bypass vulnerability in pglombardo PasswordPusher, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41308 in the wild and no public exploit code.

Affected product: pglombardo PasswordPusher. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41308/ (Markdown: https://insights.sbomify.com/CVE-2026-41308/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41308
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41308
- OSV: https://osv.dev/vulnerability/CVE-2026-41308

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41308/
Summaries are generated and may contain mistakes; the official description above is the record.
