# CVE-2026-41313: pypdf: Possible long runtimes for wrong size values in incremental mode

> An attacker can cause long runtimes and potential denial of service by crafting a PDF with a large trailer Size value in incremental mode.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** CLSA-2026-1781225618, DEBIAN-CVE-2026-41313, ECHO-d728-fdc6-1a1e, GHSA-4pxv-j86v-mhcw, MINI-5w5h-46h2-3j4r, MINI-hx7x-wfgv-gjvx, MINI-whhp-gh7c-x9g4, PYSEC-2026-3007, ROOT-APP-PYPI-CVE-2026-41313, ROOT-APP-PYPI-GHSA-4pxv-j86v-mhcw, UBUNTU-CVE-2026-41313

## What is CVE-2026-41313?

CVE-2026-41313 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 22 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

pypdf is a free and open-source pure-python PDF library. An attacker who uses a vulnerability present in versions prior to 6.10.2 can craft a PDF which leads to long runtimes. This requires loading a PDF with a large trailer `/Size` value in incremental mode. This has been fixed in pypdf 6.10.2. As a workaround, one may apply the changes from the patch manually.

Weakness: CWE-834 (Excessive Iteration)

## Which versions are affected by CVE-2026-41313?

3 open source packages ship an affected version, including pypdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.10.2 |
| `pypdf` | PyPI | All versions | 6.10.2 |
| `pypdf` | PyPI | All versions | 6.10.2 |

Products: Pypdf Project Pypdf.

## How do I fix CVE-2026-41313?

Upgrade pypdf to 6.10.2 or later.

## Is CVE-2026-41313 being exploited?

There is no known exploitation of CVE-2026-41313 in the wild and no public exploit code.

## Other vulnerabilities in Pypdf Project Pypdf

- [CVE-2026-102993](https://insights.sbomify.com/CVE-2026-102993/): pypdf: Possible large memory usage when retrieving Roman page labels (high 8.7)
- [CVE-2026-102994](https://insights.sbomify.com/CVE-2026-102994/): pypdf: Possible long runtimes/large memory usage when parsing indirect objects (high 8.7)
- [CVE-2026-102995](https://insights.sbomify.com/CVE-2026-102995/): pypdf: Possible large memory usage for large /ToUnicode streams (Follow-up 2) (high 8.7)
- [CVE-2026-102996](https://insights.sbomify.com/CVE-2026-102996/): pypdf: Possible large memory usage when parsing font data (high 8.7)
- [CVE-2026-102997](https://insights.sbomify.com/CVE-2026-102997/): pypdf: Possible long runtimes for partially malformed FlateDecode streams (Follow-up) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41313 and fix it if it is affected.

What it is: CVE-2026-41313 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 22 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41313 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.10.2
- pypdf (PyPI): affected all versions; fixed in 6.10.2
- pypdf (PyPI): affected all versions; fixed in 6.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41313/ (Markdown: https://insights.sbomify.com/CVE-2026-41313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41313
- OSV: https://osv.dev/vulnerability/CVE-2026-41313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41313/
Summaries are generated and may contain mistakes; the official description above is the record.
