# CVE-2026-41314: pypdf: Manipulated FlateDecode image dimensions can exhaust RAM

> Attackers can exhaust RAM by crafting PDFs with manipulated FlateDecode image dimensions, affecting applications using the pypdf library.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-41314, ECHO-de1c-78a8-b038, GHSA-x284-j5p8-9c5p, MINI-2cgx-g8h5-48fg, MINI-j595-4rmh-q8mx, MINI-pf42-2c6p-w953, PYSEC-2026-3026, ROOT-APP-PYPI-CVE-2026-41314, ROOT-APP-PYPI-GHSA-x284-j5p8-9c5p, UBUNTU-CVE-2026-41314

## What is CVE-2026-41314?

CVE-2026-41314 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 22 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

pypdf is a free and open-source pure-python PDF library. An attacker who uses a vulnerability present in versions prior to 6.10.2 can craft a PDF which leads to the RAM being exhausted. This requires accessing an image using `/FlateDecode` with large size values. This has been fixed in pypdf 6.10.2. As a workaround, one may apply the changes from the patch manually.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-41314?

3 open source packages ship an affected version, including pypdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.10.2 |
| `pypdf` | PyPI | All versions | 6.10.2 |
| `pypdf` | PyPI | All versions | 6.10.2 |

Products: Pypdf Project Pypdf.

## How do I fix CVE-2026-41314?

Upgrade pypdf to 6.10.2 or later.

## Is CVE-2026-41314 being exploited?

There is no known exploitation of CVE-2026-41314 in the wild and no public exploit code.

## Other vulnerabilities in Pypdf Project Pypdf

- [CVE-2026-102993](https://insights.sbomify.com/CVE-2026-102993/): pypdf: Possible large memory usage when retrieving Roman page labels (high 8.7)
- [CVE-2026-102994](https://insights.sbomify.com/CVE-2026-102994/): pypdf: Possible long runtimes/large memory usage when parsing indirect objects (high 8.7)
- [CVE-2026-102995](https://insights.sbomify.com/CVE-2026-102995/): pypdf: Possible large memory usage for large /ToUnicode streams (Follow-up 2) (high 8.7)
- [CVE-2026-102996](https://insights.sbomify.com/CVE-2026-102996/): pypdf: Possible large memory usage when parsing font data (high 8.7)
- [CVE-2026-102997](https://insights.sbomify.com/CVE-2026-102997/): pypdf: Possible long runtimes for partially malformed FlateDecode streams (Follow-up) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41314 and fix it if it is affected.

What it is: CVE-2026-41314 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 22 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41314 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.10.2
- pypdf (PyPI): affected all versions; fixed in 6.10.2
- pypdf (PyPI): affected all versions; fixed in 6.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41314/ (Markdown: https://insights.sbomify.com/CVE-2026-41314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41314
- OSV: https://osv.dev/vulnerability/CVE-2026-41314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41314/
Summaries are generated and may contain mistakes; the official description above is the record.
