# CVE-2026-41323: Kyverno: ServiceAccount token leaked to external servers via apiCall service URL

> Attackers can steal ServiceAccount tokens via unvalidated apiCall URLs, leading to full Kubernetes cluster compromise.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** BIT-kyverno-2026-41323, ECHO-c76c-b1c4-8843, GHSA-f9g8-6ppc-pqq4, GO-2026-5351, MINI-4vhr-7vhf-hw33, MINI-68vw-hcv3-3rmq, MINI-6fh3-c84g-63rv, MINI-7v35-f3jm-2mpm, MINI-876x-4x3g-v27x, MINI-87cq-g3hp-62r7, MINI-f9g3-xrvp-f2q8, MINI-gg5q-hqjr-4mrr, MINI-gpg8-mr95-6gp4, MINI-j5vm-cjmc-97v4, MINI-jv4w-mpm6-hvpp, MINI-jx4r-9m38-mv7p, MINI-pgp3-xcjr-x529, MINI-wpm6-7xpx-mww2, MINI-xxmr-rrqc-25px

## What is CVE-2026-41323?

CVE-2026-41323 is a high-severity server-side request forgery vulnerability in kyverno, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kyverno is a policy engine designed for cloud native platform engineering teams. Prior to versions 1.18.0-rc1, 1.17.2-rc1, and 1.16.4, Kyverno's apiCall feature in ClusterPolicy automatically attaches the admission controller's ServiceAccount token to outgoing HTTP requests. The service URL has no validation — it can point anywhere, including attacker-controlled servers. Since the admission controller SA has permissions to patch webhook configurations, a stolen token leads to full cluster compromise. Versions 1.18.0-rc1, 1.17.2-rc1, and 1.16.4 patch the issue.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-41323?

4 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | 1.17.0 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.17.0 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.17.0 |
| `kyverno` | Bitnami | All versions | 1.16.4, 1.17.2 |

Products: Kyverno Kyverno.

## How do I fix CVE-2026-41323?

Upgrade github.com/kyverno/kyverno to 1.17.0 or later.

## Is CVE-2026-41323 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41323 exists.

## Other vulnerabilities in kyverno

- [CVE-2026-22039](https://insights.sbomify.com/CVE-2026-22039/): Kyverno Cross-Namespace Privilege Escalation via Policy apiCall (critical 10.0)
- [CVE-2026-4789](https://insights.sbomify.com/CVE-2026-4789/): CVE-2026-4789 (critical 9.8)
- [CVE-2025-46342](https://insights.sbomify.com/CVE-2025-46342/): Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements (high 8.6)
- [CVE-2026-40868](https://insights.sbomify.com/CVE-2026-40868/): kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token (high 8.1)
- [CVE-2022-47633](https://insights.sbomify.com/CVE-2022-47633/): kyverno verifyImages rule bypass possible with malicious proxy/registry (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41323 and fix it if it is affected.

What it is: CVE-2026-41323 is a high-severity server-side request forgery vulnerability in kyverno, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41323 exists.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.17.0
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.17.0
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.17.0
- kyverno (Bitnami): affected all versions; fixed in 1.16.4, 1.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41323/ (Markdown: https://insights.sbomify.com/CVE-2026-41323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41323
- OSV: https://osv.dev/vulnerability/CVE-2026-41323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41323/
Summaries are generated and may contain mistakes; the official description above is the record.
