CVE-2026-41325 Kirby is vulnerable to authorization bypass during page, file and user creation via blueprint injection
Attackers can bypass authorization controls to create pages, files, or users by injecting blueprint options, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41325?
CVE-2026-41325 is a high-severity missing authorization vulnerability in getkirby kirby, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kirby is an open-source content management system. Kirby's user permissions control which user role is allowed to perform specific actions to content models in the CMS. These permissions are defined for each role in the user blueprint (`site/blueprints/users/...`). It is also possible to customize the permissions for each target model in the model blueprints (such as in `site/blueprints/pages/...`) using the `options` feature. The permissions and options together control the authorization of user actions. Kirby provides the `pages.create`, `files.create` and `users.create` permissions (among others). These permissions can again be set in the user blueprint and/or in the blueprint of the target model via `options`. Prior to versions 4.9.0 and 5.4.0, Kirby allowed to override the `options` during the creation of pages, files and users by injecting custom dynamic blueprint configuration into the model data. The injected `options` could include `'create' => true`, which then caused an override of the permissions and options configured by the site developer in the user and model blueprints. The problem has been patched in Kirby 4.9.0 and Kirby 5.4.0. The patched versions have updated the normalization code that is used during the creation of pages, files and users to include a filter for the `blueprint` property. This prevents the injection of dynamic blueprint configuration into the creation request.
Weakness: CWE-863
Which versions are affected by CVE-2026-41325?
4 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.0 |
getkirby/cms Packagist | All versions | 4.9.0 |
getkirby/cms Packagist | From 5.0.0 | 5.4.0 |
getkirby/cms Packagist | From 5.0.0 | 5.4.0 |
Products include Getkirby Kirby.
How do I fix CVE-2026-41325?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.0 or 5.4.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-41325 being exploited?
There is no known exploitation of CVE-2026-41325 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-6gqr-mx34-wh8r.