# CVE-2026-41325: Kirby is vulnerable to authorization bypass during page, file and user creation via blueprint injection

> Attackers can bypass authorization controls to create pages, files, or users by injecting blueprint options, requiring an upgrade to patched versions.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** GHSA-6gqr-mx34-wh8r

## What is CVE-2026-41325?

CVE-2026-41325 is a high-severity missing authorization vulnerability in getkirby kirby, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kirby is an open-source content management system. Kirby's user permissions control which user role is allowed to perform specific actions to content models in the CMS. These permissions are defined for each role in the user blueprint (`site/blueprints/users/...`). It is also possible to customize the permissions for each target model in the model blueprints (such as in `site/blueprints/pages/...`) using the `options` feature. The permissions and options together control the authorization of user actions. Kirby provides the `pages.create`, `files.create` and `users.create` permissions (among others). These permissions can again be set in the user blueprint and/or in the blueprint of the target model via `options`. Prior to versions 4.9.0 and 5.4.0, Kirby allowed to override the `options` during the creation of pages, files and users by injecting custom dynamic blueprint configuration into the model data. The injected `options` could include `'create' => true`, which then caused an override of the permissions and options configured by the site developer in the user and model blueprints. The problem has been patched in Kirby 4.9.0 and Kirby 5.4.0. The patched versions have updated the normalization code that is used during the creation of pages, files and users to include a filter for the `blueprint` property. This prevents the injection of dynamic blueprint configuration into the creation request.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-41325?

4 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 4.9.0 |
| `getkirby/cms` | Packagist | All versions | 4.9.0 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.4.0 |
| `getkirby/cms` | Packagist | From 5.0.0 | 5.4.0 |

Products: Getkirby Kirby.

## How do I fix CVE-2026-41325?

Upgrade getkirby/cms to a fixed version for your release line: 4.9.0 or 5.4.0.

## Is CVE-2026-41325 being exploited?

There is no known exploitation of CVE-2026-41325 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41325 and fix it if it is affected.

What it is: CVE-2026-41325 is a high-severity missing authorization vulnerability in getkirby kirby, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41325 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.0
- getkirby/cms (Packagist): affected all versions; fixed in 4.9.0
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.0
- getkirby/cms (Packagist): affected from 5.0.0; fixed in 5.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41325/ (Markdown: https://insights.sbomify.com/CVE-2026-41325/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41325
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41325
- OSV: https://osv.dev/vulnerability/CVE-2026-41325

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41325/
Summaries are generated and may contain mistakes; the official description above is the record.
