CVE-2026-41328 Dgraph: Pre-Auth Full Database Exfiltration via DQL Injection in NQuad Lang Field

Critical 9.1 Published Updated

Unauthenticated attackers can exfiltrate all database data via DQL injection in the NQuad Lang field when ACL is disabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41328?

CVE-2026-41328 is a critical code injection vulnerability in dgraph-io dgraph, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Dgraph is an open source distributed GraphQL database. Prior to 25.3.3, a vulnerability has been found in Dgraph that gives an unauthenticated attacker full read access to every piece of data in the database. This affects Dgraph's default configuration where ACL is not enabled. The attack requires two HTTP POSTs to port 8080. The first sets up a schema predicate with @unique @index(exact) @lang via /alter (also unauthenticated in default config). The second sends a crafted JSON mutation to /mutate?commitNow=true where a JSON key contains the predicate name followed by @ and a DQL injection payload in the language tag position. The injection exploits the addQueryIfUnique function in edgraph/server.go, which constructs DQL queries using fmt.Sprintf with unsanitized predicateName that includes the raw pred.Lang value. The Lang field is extracted from JSON mutation keys by x.PredicateLang(), which splits on @, and is never validated by any function in the codebase. The attacker injects a closing parenthesis to escape the eq() function, adds an arbitrary named query block, and uses a # comment to neutralize trailing template syntax. The injected query executes server-side and its results are returned in the HTTP response. This vulnerability is fixed in 25.3.3.

Weakness: CWE-943

Which versions are affected by CVE-2026-41328?

9 open source packages ship an affected version, including github.com/dgraph-io/dgraph, github.com/dgraph-io/dgraph/v24 and github.com/dgraph-io/dgraph/v25. It affects 1 product.

PackageAffectedFixed in
github.com/dgraph-io/dgraph GoAll versionsNone
github.com/dgraph-io/dgraph GoAll versions to 1.2.8None
github.com/dgraph-io/dgraph GoAll versions to 1.2.8None
github.com/dgraph-io/dgraph/v24 GoAll versions to 24.1.8None
github.com/dgraph-io/dgraph/v24 GoAll versions to 24.1.8None
github.com/dgraph-io/dgraph/v25 GoAll versions25.3.3
3 more packages
github.com/dgraph-io/dgraph/v25 GoAll versions25.3.3
github.com/dgraph-io/dgraph/v25 GoAll versions25.3.3
github.com/hypermodeinc/dgraph/v24 GoAll versions24.1.9

Products include Dgraph Dgraph.

How do I fix CVE-2026-41328?

Upgrade to a fixed version.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-41328 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41328 exists.

Sources

Also known as GHSA-x92x-px7w-4gx4, GO-2026-5749.

Is CVE-2026-41328 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free