CVE-2026-41330 OpenClaw < 2026.3.31 - Environment Variable Override via Host Exec Policy
Attackers can bypass proxy, TLS, and Docker security controls by overriding environment variables in OpenClaw host exec policies.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41330?
CVE-2026-41330 is a low-severity vulnerability in Openclaw Openclaw, published on 20 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
OpenClaw before 2026.3.31 contains an environment variable override vulnerability in host exec policy that fails to properly enforce proxy, TLS, Docker, and Git TLS controls. Attackers can bypass security controls by overriding environment variables to circumvent proxy settings, TLS verification, Docker restrictions, and Git TLS enforcement.
Weakness: CWE-453
Which versions are affected by CVE-2026-41330?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.31 |
openclaw npm | All versions | 2026.3.31 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-41330?
Upgrade openclaw to 2026.3.31 or later.
Is CVE-2026-41330 being exploited?
There is no known exploitation of CVE-2026-41330 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-9gp8-hjxr-6f34, MINI-jrmr-h6jc-f2hp.