CVE-2026-41341 OpenClaw < 2026.3.31 - Component Interaction Misclassification in Discord Extension
Attackers can bypass group DM policy enforcement or trigger incorrect session handling due to a logic error in Discord component interaction routing.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41341?
CVE-2026-41341 is a low-severity vulnerability in Openclaw Openclaw, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.3.31 contains a logic error in Discord component interaction routing that misclassifies group direct messages as direct messages in extensions/discord/src/monitor/agent-components-helpers.ts. Attackers can exploit this misclassification to bypass group DM policy enforcement or trigger incorrect session handling.
Weakness: CWE-351
Which versions are affected by CVE-2026-41341?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.31 |
openclaw npm | All versions | 2026.3.31 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-41341?
Upgrade openclaw to 2026.3.31 or later.
Is CVE-2026-41341 being exploited?
There is no known exploitation of CVE-2026-41341 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-6336-qqw9-v6x6, MINI-3vx6-h5vc-vvm2, MINI-458w-v9xq-hwh2.