CVE-2026-41346 OpenClaw 2026.2.26 < 2026.3.31 - Denial of Service via Improper Pending Pairing Request Cap Enforcement

Medium 6.3 Published Updated

Remote attackers can exhaust shared pending pairing windows by submitting requests from other accounts, blocking legitimate pairing challenges and causing denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41346?

CVE-2026-41346 is a medium-severity denial of service vulnerability in Openclaw Openclaw, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenClaw 2026.2.26 before 2026.3.31 enforces pending pairing-request caps per channel file instead of per account, allowing attackers to exhaust the shared pending window. Remote attackers can submit pairing requests from other accounts to block new pairing challenges on unaffected accounts, causing denial of service.

Weakness: CWE-799

Which versions are affected by CVE-2026-41346?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2026.2.262026.3.31
openclaw npmFrom 2026.2.262026.3.31

Products include Openclaw Openclaw.

How do I fix CVE-2026-41346?

Upgrade openclaw to 2026.3.31 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-41346 being exploited?

There is no known exploitation of CVE-2026-41346 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-wwfp-w96m-c6x8, MINI-82q4-78f3-h692, MINI-xgwx-3cm6-24m6.

Is CVE-2026-41346 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free