# CVE-2026-41346: OpenClaw 2026.2.26 < 2026.3.31 - Denial of Service via Improper Pending Pairing Request Cap Enforcement

> Remote attackers can exhaust shared pending pairing windows by submitting requests from other accounts, blocking legitimate pairing challenges and causing denial of service.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** GHSA-wwfp-w96m-c6x8, MINI-82q4-78f3-h692, MINI-xgwx-3cm6-24m6

## What is CVE-2026-41346?

CVE-2026-41346 is a medium-severity denial of service vulnerability in Openclaw Openclaw, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenClaw 2026.2.26 before 2026.3.31 enforces pending pairing-request caps per channel file instead of per account, allowing attackers to exhaust the shared pending window. Remote attackers can submit pairing requests from other accounts to block new pairing challenges on unaffected accounts, causing denial of service.

Weakness: CWE-799 (Improper Control of Interaction Frequency)

## Which versions are affected by CVE-2026-41346?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | From 2026.2.26 | 2026.3.31 |
| `openclaw` | npm | From 2026.2.26 | 2026.3.31 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-41346?

Upgrade openclaw to 2026.3.31 or later.

## Is CVE-2026-41346 being exploited?

There is no known exploitation of CVE-2026-41346 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41346 and fix it if it is affected.

What it is: CVE-2026-41346 is a medium-severity denial of service vulnerability in Openclaw Openclaw, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41346 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected from 2026.2.26; fixed in 2026.3.31
- openclaw (npm): affected from 2026.2.26; fixed in 2026.3.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41346/ (Markdown: https://insights.sbomify.com/CVE-2026-41346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41346
- OSV: https://osv.dev/vulnerability/CVE-2026-41346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41346/
Summaries are generated and may contain mistakes; the official description above is the record.
