# CVE-2026-4137: Incomplete Fix for CVE-2025-10279: Insecure Temporary Directory Permissions in mlflow/mlflow

> Local attackers can tamper with world-writable temporary model artifacts to achieve arbitrary code execution via unsafe deserialization in MLflow.

- **Severity:** High 7.0 (`CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 May 2026
- **Updated:** 19 May 2026
- **Also known as:** BIT-mlflow-2026-4137, CLSA-2026-1780879898, GHSA-f2m9-wcf4-cwwx, PYSEC-2026-2655

## What is CVE-2026-4137?

CVE-2026-4137 is a high-severity unsafe deserialization vulnerability in Lfprojects Mlflow, published on 18 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In mlflow/mlflow versions prior to 3.11.0, the `get_or_create_nfs_tmp_dir()` function in `mlflow/utils/file_utils.py` creates temporary directories with world-writable permissions (0o777), and the `_create_model_downloading_tmp_dir()` function in `mlflow/pyfunc/__init__.py` creates directories with group-writable permissions (0o770). These insecure permissions allow local attackers to tamper with model artifacts, such as cloudpickle-serialized Python objects, and achieve arbitrary code execution when the tampered artifacts are deserialized via `cloudpickle.load()`. This vulnerability is particularly critical in environments with shared NFS mounts, such as Databricks, where NFS is enabled by default. The issue is a continuation of the vulnerability class addressed in CVE-2025-10279, which was only partially fixed.

Weakness: CWE-378 (Creation of Temporary File With Insecure Permissions)

## Which versions are affected by CVE-2026-4137?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.11.0 |
| `mlflow` | PyPI | All versions | 3.11.0 |
| `mlflow` | PyPI | From 1.26.0 | 3.11.0 |
| `mlflow` | PyPI | From 1.26.0 | 3.11.0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2026-4137?

Upgrade mlflow to 3.11.0 or later.

## Is CVE-2026-4137 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4137 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4137 and fix it if it is affected.

What it is: CVE-2026-4137 is a high-severity unsafe deserialization vulnerability in Lfprojects Mlflow, published on 18 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-4137 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.11.0
- mlflow (PyPI): affected all versions; fixed in 3.11.0
- mlflow (PyPI): affected from 1.26.0; fixed in 3.11.0
- mlflow (PyPI): affected from 1.26.0; fixed in 3.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4137/ (Markdown: https://insights.sbomify.com/CVE-2026-4137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4137
- OSV: https://osv.dev/vulnerability/CVE-2026-4137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4137/
Summaries are generated and may contain mistakes; the official description above is the record.
