# CVE-2026-41371: OpenClaw < 2026.3.28 - Privilege Escalation via chat.send Reset Command

> Attackers with write scope can escalate privileges to perform admin-only session resets, forcing new session IDs and archiving transcripts.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-592j-4mrx-v257, GHSA-5r8f-96gm-5j6g, MINI-pcj6-jmfv-9q92, MINI-x295-jmwm-22vf

## What is CVE-2026-41371?

CVE-2026-41371 is a high-severity vulnerability in Openclaw Openclaw, published on 27 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw before 2026.3.28 contains a privilege escalation vulnerability in chat.send that allows write-scoped gateway callers to trigger admin-only session reset operations. Attackers can rotate target sessions, archive prior transcript state, and force new session IDs without requiring admin scope by exploiting improper authorization checks in the chat.send path.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-41371?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.3.28 |
| `openclaw` | npm | All versions | 2026.3.28 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-41371?

Upgrade openclaw to 2026.3.28 or later.

## Is CVE-2026-41371 being exploited?

There is no known exploitation of CVE-2026-41371 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41371 and fix it if it is affected.

What it is: CVE-2026-41371 is a high-severity vulnerability in Openclaw Openclaw, published on 27 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41371 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.3.28
- openclaw (npm): affected all versions; fixed in 2026.3.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41371/ (Markdown: https://insights.sbomify.com/CVE-2026-41371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41371
- OSV: https://osv.dev/vulnerability/CVE-2026-41371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41371/
Summaries are generated and may contain mistakes; the official description above is the record.
