CVE-2026-41377 OpenClaw < 2026.3.31 - Fail-Open Security Scan Bypass in Plugin Installation
Attackers can bypass security scans to install malicious plugins in OpenClaw by exploiting fail-open behavior during installation failures.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-41377?
CVE-2026-41377 is a medium-severity vulnerability in Openclaw Openclaw, published on 28 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
OpenClaw before 2026.3.31 contains a fail-open vulnerability in the plugin installation flow where security scan failures do not block installation. Attackers can exploit scan failures to install untrusted plugins when operators proceed despite visible scan warnings.
Weakness: CWE-636
Which versions are affected by CVE-2026-41377?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.31 |
openclaw npm | All versions | 2026.3.31 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-41377?
Upgrade openclaw to 2026.3.31 or later.
Is CVE-2026-41377 being exploited?
There is no known exploitation of CVE-2026-41377 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-cwq8-6f96-g3q4, MINI-vj9q-4xjr-pjg4.