CVE-2026-41386 OpenClaw < 2026.3.22 - Privilege Escalation via Unbound Bootstrap Setup Codes
Attackers can escalate privileges during device pairing by exploiting unbound bootstrap setup codes in OpenClaw devices.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41386?
CVE-2026-41386 is a critical vulnerability in Openclaw Openclaw, published on 28 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OpenClaw before 2026.3.22 contains a privilege escalation vulnerability where bootstrap setup codes are not bound to intended device roles and scopes during pairing. Attackers can exploit this during first-use device pairing to escalate privileges beyond their intended role and scope.
Weakness: CWE-648
Which versions are affected by CVE-2026-41386?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.22 |
openclaw npm | All versions | 2026.3.22 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-41386?
Upgrade openclaw to 2026.3.22 or later.
Is CVE-2026-41386 being exploited?
There is no known exploitation of CVE-2026-41386 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-gg9v-mgcp-v6m7, MINI-c4cf-3rg4-6vvj.