CVE-2026-41396 OpenClaw < 2026.3.31 - Environment Variable Override of Plugin Trust Root
Attackers can override plugin trust roots via environment variables to inject malicious plugins, leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-41396?
CVE-2026-41396 is a high-severity vulnerability in Openclaw Openclaw, published on 28 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
OpenClaw before 2026.3.31 allows workspace .env files to override the OPENCLAW_BUNDLED_PLUGINS_DIR environment variable, compromising plugin trust verification. Attackers with control over workspace configuration can inject malicious plugins by overriding the bundled plugin trust root directory.
Weakness: CWE-829
Which versions are affected by CVE-2026-41396?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.3.31 |
openclaw npm | All versions | 2026.3.31 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-41396?
Upgrade openclaw to 2026.3.31 or later.
Is CVE-2026-41396 being exploited?
There is no known exploitation of CVE-2026-41396 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-qcj9-wwgw-6gm8, MINI-mr69-4466-vvrg.