{"answers":{"affected":"2 open source packages ship an affected version, including openclaw. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-41396 in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.3.31 or later.","what":"CVE-2026-41396 is a high-severity vulnerability in Openclaw Openclaw, published on 28 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-41396 and fix it if it is affected.\n\nWhat it is: CVE-2026-41396 is a high-severity vulnerability in Openclaw Openclaw, published on 28 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-41396 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.3.31\n- openclaw (npm): affected all versions; fixed in 2026.3.31\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41396/ (Markdown: https://insights.sbomify.com/CVE-2026-41396/index.md)","id":"CVE-2026-41396","markdown":"https://insights.sbomify.com/CVE-2026-41396/index.md","name":"CVE-2026-41396","record":{"aliases":["GHSA-qcj9-wwgw-6gm8","MINI-mr69-4466-vvrg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenClaw plugin system","requires_auth":"none","summary":"Attackers can override plugin trust roots via environment variables to inject malicious plugins, leading to code execution.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"openclaw","vendor":"openclaw"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"OpenClaw before 2026.3.31 allows workspace .env files to override the OPENCLAW_BUNDLED_PLUGINS_DIR environment variable, compromising plugin trust verification. Attackers with control over workspace configuration can inject malicious plugins by overriding the bundled plugin trust root directory.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenClaw \u003c 2026.3.31 - Environment Variable Override of Plugin Trust Root","id":"CVE-2026-41396","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"openclaw:openclaw","products":["openclaw:openclaw"],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"OpenClaw \u003c 2026.3.31 - Sandbox Escape via Unrestricted File Sync and Symlink Traversal","id":"CVE-2026-41397"},"packages":[{"ecosystem":"npm","fixed":["2026.3.31"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-qcj9-wwgw-6gm8"},{"ecosystem":"npm","fixed":["2026.3.31"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-qcj9-wwgw-6gm8"}],"prev":{"headline":"OpenClaw \u003c 2026.3.28 - Webhook Replay via Query Parameter Reordering in Plivo V3","id":"CVE-2026-41395"},"products":["OpenClaw"],"published":"2026-04-28","related":[{"cvss_score":9.9,"headline":"Security feature bypass in OpenClaw","id":"CVE-2026-28363","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-30741","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":9.4,"headline":"OpenClaw \u003c 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval","id":"CVE-2026-33579","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.4,"headline":"OpenClaw \u003c 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate","id":"CVE-2026-32922","kev_date_added":null,"published":"2026-03-29"},{"cvss_score":9.4,"headline":"OpenClaw \u003c 2026.3.11 - Approval Bypass via Unrecognized Script Runners","id":"CVE-2026-32978","kev_date_added":null,"published":"2026-03-29"},{"cvss_score":9.4,"headline":"OpenClaw \u003c 2026.3.12 - Scope Elevation in WebSocket Shared-Auth Connections","id":"CVE-2026-22172","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":9.4,"headline":"OpenClaw \u003c 2026.2.14 - Remote Code Execution via Node Invoke Approval Bypass","id":"CVE-2026-28466","kev_date_added":null,"published":"2026-03-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-29","vendors":["OpenClaw"]},"summary":"Attackers can override plugin trust roots via environment variables to inject malicious plugins, leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-41396/"}