# CVE-2026-41413: Istio Vulnerable to SSRF via RequestAuthentication jwksUri

> Attackers can exploit Istio's RequestAuthentication to perform SSRF, leaking sensitive internal data to Envoy proxies.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-fgw5-hp8f-xfhc, GO-2026-5363, MINI-25p6-8qxc-27qp, MINI-2c7p-2jcm-q97p, MINI-2h2g-6f3h-pm9h, MINI-4f98-cr4v-m376, MINI-53vx-3cwm-fgj6, MINI-5xmp-6qrf-vc7f, MINI-63xm-64h7-pv4p, MINI-6cvv-5pw6-xp5w, MINI-8v4h-qwwj-xr6f, MINI-9f7q-rgr6-pv59, MINI-f42x-w5fw-v8c6, MINI-fj2c-6ppr-ppjm, MINI-hxwv-3vqc-rm2x, MINI-mm88-36mx-2ff7, MINI-mv5c-fm42-fv54, MINI-q679-qmf5-4788, MINI-vvfw-c73r-3x3r, MINI-x34f-58v4-97v7

## What is CVE-2026-41413?

CVE-2026-41413 is a medium-severity server-side request forgery vulnerability in istio, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Istio is an open platform to connect, manage, and secure microservices. Prior to versions 1.28.6 and 1.29.2, when a RequestAuthentication resource is created with a jwksUri pointing to an internal service, istiod makes an unauthenticated HTTP GET request to that URL without filtering out localhost or link local ips. This can result in sensitive data being distributed to Envoy proxies via xDS configuration. This issue has been patched in versions 1.28.6 and 1.29.2.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-41413?

3 open source packages ship an affected version, including istio.io/istio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `istio.io/istio` | Go | All versions | 0.0.0-20260410004459-189832a289c1 |
| `istio.io/istio` | Go | All versions | 0.0.0-20260410004459-189832a289c1 |
| `istio.io/istio` | Go | All versions | 0.0.0-20260410004459-189832a289c1 |

Products: Istio Istio.

## How do I fix CVE-2026-41413?

Upgrade istio.io/istio to 0.0.0-20260410004459-189832a289c1 or later.

## Is CVE-2026-41413 being exploited?

There is no known exploitation of CVE-2026-41413 in the wild and no public exploit code.

## Other vulnerabilities in istio

- [CVE-2021-31921](https://insights.sbomify.com/CVE-2021-31921/): Missing authorization in n/a (critical 9.8)
- [CVE-2021-34824](https://insights.sbomify.com/CVE-2021-34824/): Information disclosure in n/a (high 8.8)
- [CVE-2026-31837](https://insights.sbomify.com/CVE-2026-31837/): Istio JWKS resolver to prevent private key material from being exposed when JWKS fetch fails. (high 8.7)
- [CVE-2021-39155](https://insights.sbomify.com/CVE-2021-39155/): Authorization Policy Bypass Due to Case Insensitive Host Comparison (high 8.3)
- [CVE-2021-39156](https://insights.sbomify.com/CVE-2021-39156/): Fragments in Path May Lead to Authorization Policy Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41413 and fix it if it is affected.

What it is: CVE-2026-41413 is a medium-severity server-side request forgery vulnerability in istio, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41413 in the wild and no public exploit code.

Affected packages and fixed versions:
- istio.io/istio (Go): affected all versions; fixed in 0.0.0-20260410004459-189832a289c1
- istio.io/istio (Go): affected all versions; fixed in 0.0.0-20260410004459-189832a289c1
- istio.io/istio (Go): affected all versions; fixed in 0.0.0-20260410004459-189832a289c1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41413/ (Markdown: https://insights.sbomify.com/CVE-2026-41413/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41413
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41413
- OSV: https://osv.dev/vulnerability/CVE-2026-41413

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41413/
Summaries are generated and may contain mistakes; the official description above is the record.
