CVE-2026-41415 PJSIP: SIP Multipart CID URI Length Underflow

Medium 6.7 Published Updated

An out-of-bounds read in PJSIP allows attackers to cause denial of service or disclose memory contents via malformed SIP messages.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41415?

CVE-2026-41415 is a medium-severity memory corruption vulnerability in pjsip pjproject, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, there is an out-of-bounds read when parsing a malformed Content-ID URI in SIP multipart message body. Insufficient length validation can cause reads beyond the intended buffer bounds. This vulnerability is fixed in 2.17.

Weakness: CWE-125

Which versions are affected by CVE-2026-41415?

It affects 1 product.

Products include Teluu Pjsip.

How do I fix CVE-2026-41415?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-41415 being exploited?

There is no known exploitation of CVE-2026-41415 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-41415, GHSA-935m-fmf5-j4pm, UBUNTU-CVE-2026-41415.

Is CVE-2026-41415 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free