{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-41415 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-41415 is a medium-severity memory corruption vulnerability in pjsip pjproject, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41415 and fix it if it is affected.\n\nWhat it is: CVE-2026-41415 is a medium-severity memory corruption vulnerability in pjsip pjproject, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-41415 in the wild and no public exploit code.\n\nAffected product: pjsip pjproject. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41415/ (Markdown: https://insights.sbomify.com/CVE-2026-41415/index.md)","id":"CVE-2026-41415","markdown":"https://insights.sbomify.com/CVE-2026-41415/index.md","name":"CVE-2026-41415","record":{"aliases":["DEBIAN-CVE-2026-41415","GHSA-935m-fmf5-j4pm","UBUNTU-CVE-2026-41415"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PJSIP SIP library","requires_auth":"none","summary":"An out-of-bounds read in PJSIP allows attackers to cause denial of service or disclose memory contents via malformed SIP messages.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pjsip","vendor":"teluu"}],"cvss":{"score":6.7,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, there is an out-of-bounds read when parsing a malformed Content-ID URI in SIP multipart message body. Insufficient length validation can cause reads beyond the intended buffer bounds. This vulnerability is fixed in 2.17.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PJSIP: SIP Multipart CID URI Length Underflow","id":"CVE-2026-41415","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"PJSIP: Asymmetric ptime integer overflow in Media Stream","id":"CVE-2026-41416"},"packages":[],"prev":{"headline":"Skim: Arbitrary code execution via pull_request_target fork checkout in pr.yml","id":"CVE-2026-41414"},"products":["pjproject"],"published":"2026-04-24","related":[{"cvss_score":9.8,"headline":"PJSIP has use-after-free vulnerability in SRTP media transport","id":"CVE-2023-38703","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":9.1,"headline":"Media transport downgrade from the secure version (SRTP) to non-secure (RTP) in pjsip","id":"CVE-2022-39269","kev_date_added":null,"published":"2022-10-06"},{"cvss_score":8.8,"headline":"PJSIP: Stack overflow handling Service-Route headers in a registration response","id":"CVE-2026-57161","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":8.8,"headline":"PJSIP: Stack overflow parsing SDP a=crypto attributes","id":"CVE-2026-57162","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":8.8,"headline":"PJSIP: Stack overflow parsing a TLS peer certificate's SubjectAltName in GnuTLS backend","id":"CVE-2026-57163","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":8.4,"headline":"PJSIP: SDP parser out-of-bounds write in remote payload-type map maintenance","id":"CVE-2026-57159","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":8.3,"headline":"PJSIP: Heap overflow in the HTTP client","id":"CVE-2026-57164","kev_date_added":null,"published":"2026-09-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-24","vendors":["pjsip"]},"summary":"An out-of-bounds read in PJSIP allows attackers to cause denial of service or disclose memory contents via malformed SIP messages.","url":"https://insights.sbomify.com/CVE-2026-41415/"}