CVE-2026-41416 PJSIP: Asymmetric ptime integer overflow in Media Stream

High 8.1 Published Updated

An integer overflow in PJSIP's media stream buffer calculation allows attackers to cause denial of service or memory corruption via crafted SDP.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41416?

CVE-2026-41416 is a high-severity vulnerability in pjsip pjproject, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, there is an integer overflow in media stream buffer size calculation when processing SDP with asymmetric ptime configuration. The overflow may result in an undersized buffer allocation, which can lead to unexpected application termination or memory corruption This vulnerability is fixed in 2.17.

Weakness: CWE-190

Which versions are affected by CVE-2026-41416?

It affects 1 product.

Products include Teluu Pjsip.

How do I fix CVE-2026-41416?

Upgrade to a fixed version.

Is CVE-2026-41416 being exploited?

There is no known exploitation of CVE-2026-41416 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-41416, GHSA-f33g-8hjq-62xr, UBUNTU-CVE-2026-41416.

Is CVE-2026-41416 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free