# CVE-2026-41419: 4ga Boards: Import Path Traversal Leads to Arbitrary File Read

> An authenticated user with import privileges can exploit path traversal to read arbitrary host files via board attachments, leading to unauthorized data disclosure.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** GHSA-rrjq-7x8g-cmgm

## What is CVE-2026-41419?

CVE-2026-41419 is a high-severity path traversal vulnerability in RARgames 4gaBoards, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

4ga Boards is a boards system for realtime project management. Prior to 3.3.5, a path traversal vulnerability allows an authenticated user with board import privileges to make the server ingest arbitrary host files as board attachments during BOARDS archive import. Once imported, the file can be downloaded through the normal application interface, resulting in unauthorized local file disclosure. This vulnerability is fixed in 3.3.5.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-41419?


## How do I fix CVE-2026-41419?

No fix has been published for CVE-2026-41419 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41419 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41419 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41419 and fix it if it is affected.

What it is: CVE-2026-41419 is a high-severity path traversal vulnerability in RARgames 4gaBoards, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41419 exists.

Affected product: RARgames 4gaBoards. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41419/ (Markdown: https://insights.sbomify.com/CVE-2026-41419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41419
- OSV: https://osv.dev/vulnerability/CVE-2026-41419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41419/
Summaries are generated and may contain mistakes; the official description above is the record.
