# CVE-2026-41422: Daptin vulnerable to SQL injection via unvalidated goqu.L() calls in aggregate API

> Authenticated users can inject arbitrary SQL via unvalidated parameters in the aggregate API, allowing unauthorized data access or modification.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-rw2c-8rfq-gwfv, GO-2026-5640

## What is CVE-2026-41422?

CVE-2026-41422 is a high-severity SQL injection vulnerability in daptin, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Daptin is a GraphQL/JSON-API headless CMS. Prior to version 0.11.4, the /aggregate/:typename endpoint accepted column and group query parameters that were passed verbatim to goqu.L() — a raw SQL literal expression builder — without any validation. This bypassed all parameterization and allowed authenticated users with any valid session to inject arbitrary SQL expressions. This issue has been patched in version 0.11.4.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-41422?

3 open source packages ship an affected version, including github.com/daptin/daptin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/daptin/daptin` | Go | All versions | 0.11.4 |
| `github.com/daptin/daptin` | Go | All versions | 0.11.4 |
| `github.com/daptin/daptin` | Go | All versions | 0.11.4 |

## How do I fix CVE-2026-41422?

Upgrade github.com/daptin/daptin to 0.11.4 or later.

## Is CVE-2026-41422 being exploited?

There is no known exploitation of CVE-2026-41422 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41422 and fix it if it is affected.

What it is: CVE-2026-41422 is a high-severity SQL injection vulnerability in daptin, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41422 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/daptin/daptin (Go): affected all versions; fixed in 0.11.4
- github.com/daptin/daptin (Go): affected all versions; fixed in 0.11.4
- github.com/daptin/daptin (Go): affected all versions; fixed in 0.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41422/ (Markdown: https://insights.sbomify.com/CVE-2026-41422/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41422
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41422
- OSV: https://osv.dev/vulnerability/CVE-2026-41422

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41422/
Summaries are generated and may contain mistakes; the official description above is the record.
