CVE-2026-41423 Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server

High 8.7 Published Updated

Attackers can exploit SSRF in Angular Platform-Server to redirect internal requests to attacker-controlled domains, exposing internal APIs or metadata.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41423?

CVE-2026-41423 is a high-severity server-side request forgery vulnerability in angular, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8, a Server-Side Request Forgery (SSRF) vulnerability exists in @angular/platform-server due to improper handling of URLs during Server-Side Rendering (SSR). When an attacker sends a request such as GET /\evil.com/ HTTP/1.1 the server engine (Express, etc.) passes the URL string to Angular’s rendering functions. Because the URL parser normalizes the backslash to a forward slash for HTTP/HTTPS schemes, the internal state of the application is hijacked to believe the current origin is evil.com. This misinterpretation tricks the application into treating the attacker’s domain as the local origin. Consequently, any relative HttpClient requests or PlatformLocation.hostname references are redirected to the attacker controlled server, potentially exposing internal APIs or metadata services. This issue has been patched in versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8.

Weakness: CWE-918

Which versions are affected by CVE-2026-41423?

10 open source packages ship an affected version, including @angular/platform-server. It affects 1 product.

PackageAffectedFixed in
@angular/platform-server npmAll versions to 18.2.14None
@angular/platform-server npmAll versions to 18.2.14None
@angular/platform-server npmFrom 19.0.0-next.019.2.21
@angular/platform-server npmFrom 19.0.0-next.019.2.21
@angular/platform-server npmFrom 20.0.0-next.020.3.19
@angular/platform-server npmFrom 20.0.0-next.020.3.19
4 more packages
@angular/platform-server npmFrom 21.0.0-next.021.2.9
@angular/platform-server npmFrom 21.0.0-next.021.2.9
@angular/platform-server npmFrom 22.0.0-next.022.0.0-next.8
@angular/platform-server npmFrom 22.0.0-next.022.0.0-next.8

Products include Angular Angular.

How do I fix CVE-2026-41423?

Upgrade @angular/platform-server to a fixed version for your release line: 19.2.21, 20.3.19, 21.2.9 or 22.0.0-next.8.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-41423 being exploited?

There is no known exploitation of CVE-2026-41423 in the wild and no public exploit code.

Sources

Also known as CLSA-2026-1792490699, CLSA-2026-1792490700, CLSA-2026-1792490701, CLSA-2026-1792490702, CLSA-2026-1792490703, CLSA-2026-1792490704 and 11 more.

Is CVE-2026-41423 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free