# CVE-2026-41423: Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server

> Attackers can exploit SSRF in Angular Platform-Server to redirect internal requests to attacker-controlled domains, exposing internal APIs or metadata.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** CLSA-2026-1792490699, CLSA-2026-1792490700, CLSA-2026-1792490701, CLSA-2026-1792490702, CLSA-2026-1792490703, CLSA-2026-1792490704, CLSA-2026-1792490711, CLSA-2026-1792490712, CLSA-2026-1792490713, CLSA-2026-1792490714, CLSA-2026-1792490715, CLSA-2026-1792490717, CLSA-2026-1792490718, CLSA-2026-1792490719, DEBIAN-CVE-2026-41423, GHSA-45q2-gjvg-7973, UBUNTU-CVE-2026-41423

## What is CVE-2026-41423?

CVE-2026-41423 is a high-severity server-side request forgery vulnerability in angular, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8, a Server-Side Request Forgery (SSRF) vulnerability exists in @angular/platform-server due to improper handling of URLs during Server-Side Rendering (SSR). When an attacker sends a request such as GET /\evil.com/ HTTP/1.1 the server engine (Express, etc.) passes the URL string to Angular’s rendering functions. Because the URL parser normalizes the backslash to a forward slash for HTTP/HTTPS schemes, the internal state of the application is hijacked to believe the current origin is evil.com. This misinterpretation tricks the application into treating the attacker’s domain as the local origin. Consequently, any relative HttpClient requests or PlatformLocation.hostname references are redirected to the attacker controlled server, potentially exposing internal APIs or metadata services. This issue has been patched in versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-41423?

10 open source packages ship an affected version, including @angular/platform-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/platform-server` | npm | All versions to 18.2.14 | None |
| `@angular/platform-server` | npm | All versions to 18.2.14 | None |
| `@angular/platform-server` | npm | From 19.0.0-next.0 | 19.2.21 |
| `@angular/platform-server` | npm | From 19.0.0-next.0 | 19.2.21 |
| `@angular/platform-server` | npm | From 20.0.0-next.0 | 20.3.19 |
| `@angular/platform-server` | npm | From 20.0.0-next.0 | 20.3.19 |
| `@angular/platform-server` | npm | From 21.0.0-next.0 | 21.2.9 |
| `@angular/platform-server` | npm | From 21.0.0-next.0 | 21.2.9 |
| `@angular/platform-server` | npm | From 22.0.0-next.0 | 22.0.0-next.8 |
| `@angular/platform-server` | npm | From 22.0.0-next.0 | 22.0.0-next.8 |

Products: Angular Angular.

## How do I fix CVE-2026-41423?

Upgrade @angular/platform-server to a fixed version for your release line: 19.2.21, 20.3.19, 21.2.9 or 22.0.0-next.8.

## Is CVE-2026-41423 being exploited?

There is no known exploitation of CVE-2026-41423 in the wild and no public exploit code.

## Other vulnerabilities in angular

- [CVE-2026-68945](https://insights.sbomify.com/CVE-2026-68945/): Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning (high 8.8)
- [CVE-2026-46417](https://insights.sbomify.com/CVE-2026-46417/): Angular: SSRF via Hostname Hijacking in @angular/platform-server (high 8.8)
- [CVE-2026-50168](https://insights.sbomify.com/CVE-2026-50168/): Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass (high 8.8)
- [CVE-2026-54266](https://insights.sbomify.com/CVE-2026-54266/): Angular: Weak 32-Bit Cache Key Hashing in `HttpTransferCache` Leading to Cross-Request Data Leakage and State Poisoning (high 8.8)
- [CVE-2026-88056](https://insights.sbomify.com/CVE-2026-88056/): Angular: SSRF and Cross-Origin Credential Disclosure via URL Resolution Discrepancy in SSR (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41423 and fix it if it is affected.

What it is: CVE-2026-41423 is a high-severity server-side request forgery vulnerability in angular, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41423 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/platform-server (npm): affected all versions up to 18.2.14; no fix listed
- @angular/platform-server (npm): affected all versions up to 18.2.14; no fix listed
- @angular/platform-server (npm): affected from 19.0.0-next.0; fixed in 19.2.21
- @angular/platform-server (npm): affected from 19.0.0-next.0; fixed in 19.2.21
- @angular/platform-server (npm): affected from 20.0.0-next.0; fixed in 20.3.19
- @angular/platform-server (npm): affected from 20.0.0-next.0; fixed in 20.3.19
- @angular/platform-server (npm): affected from 21.0.0-next.0; fixed in 21.2.9
- @angular/platform-server (npm): affected from 21.0.0-next.0; fixed in 21.2.9
- @angular/platform-server (npm): affected from 22.0.0-next.0; fixed in 22.0.0-next.8
- @angular/platform-server (npm): affected from 22.0.0-next.0; fixed in 22.0.0-next.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41423/ (Markdown: https://insights.sbomify.com/CVE-2026-41423/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41423
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41423
- OSV: https://osv.dev/vulnerability/CVE-2026-41423

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41423/
Summaries are generated and may contain mistakes; the official description above is the record.
