CVE-2026-41427 Better Auth OAuth 2.1 Provider: Unprivileged users can register OAuth clients
Authenticated users can bypass client registration restrictions to register OAuth clients with arbitrary redirect URIs, enabling potential account takeover or phishing.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41427?
CVE-2026-41427 is a high-severity missing authorization vulnerability in better-auth, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Better Auth is an authentication and authorization library for TypeScript. Prior to 1.6.5, the clientPrivileges option documents a create action, but the OAuth client creation endpoints did not invoke the hook before persisting new clients. Deployments that configured clientPrivileges to restrict client registration were not actually restricted — any authenticated user could reach the create endpoints and register an OAuth client with attacker-chosen redirect URIs and metadata. This vulnerability is fixed in 1.6.5.
Weakness: CWE-863
Which versions are affected by CVE-2026-41427?
4 open source packages ship an affected version, including @better-auth/oauth-provider. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@better-auth/oauth-provider npm | From 1.4.8-beta.7 | 1.6.5 |
@better-auth/oauth-provider npm | From 1.4.8-beta.7 | 1.6.5 |
@better-auth/oauth-provider npm | From 1.7.0-beta.0 to 1.7.0-beta.1 | None |
@better-auth/oauth-provider npm | From 1.7.0-beta.0 to 1.7.0-beta.1 | None |
Products include Better-Auth Better-Auth\/Oauth-Provider.
How do I fix CVE-2026-41427?
Upgrade @better-auth/oauth-provider to 1.6.5 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-41427 being exploited?
There is no known exploitation of CVE-2026-41427 in the wild and no public exploit code.
Other vulnerabilities in better-auth
Sources
Also known as GHSA-xr8f-h2gw-9xh6.