# CVE-2026-41432: New API: Stripe Webhook Signature Bypass via Empty Secret Enables Unlimited Quota Fraud

> An unauthenticated attacker can bypass Stripe webhook signature verification to credit arbitrary quota to their account without payment.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 12 May 2026
- **Also known as:** GHSA-xff3-5c9p-2mr4, GO-2026-5753

## What is CVE-2026-41432?

CVE-2026-41432 is a high-severity authentication bypass vulnerability in QuantumNous new-api, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. Prior to version 0.12.10, a vulnerability exists in the Stripe webhook handler that allows an unauthenticated attacker to forge webhook events and credit arbitrary quota to their account without making any payment. This issue has been patched in version 0.12.10.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-863 (Incorrect Authorization), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-41432?

3 open source packages ship an affected version, including github.com/QuantumNous/new-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/QuantumNous/new-api` | Go | All versions | 0.12.10 |
| `github.com/QuantumNous/new-api` | Go | All versions | 0.12.10 |
| `github.com/QuantumNous/new-api` | Go | All versions | 0.12.10 |

Products: Newapi New Api.

## How do I fix CVE-2026-41432?

Upgrade github.com/QuantumNous/new-api to 0.12.10 or later.

## Is CVE-2026-41432 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41432 exists.

Public exploit code:

- New API < v0.12.10 - Stripe Webhook Bypass (nuclei): http/cves/2026/CVE-2026-41432.yaml

## Other vulnerabilities in QuantumNous new-api

- [CVE-2025-55573](https://insights.sbomify.com/CVE-2025-55573/): Cross-site scripting in n/a (high 8.8)
- [CVE-2026-33655](https://insights.sbomify.com/CVE-2026-33655/): New API: SSRF Protection Bypass via Unresolved Hostname in Notification URLs (high 7.7)
- [CVE-2026-25802](https://insights.sbomify.com/CVE-2026-25802/): New API has Potential XSS in its MarkdownRenderer component (high 7.6)
- [CVE-2026-42339](https://insights.sbomify.com/CVE-2026-42339/): New API: SSRF Filter Bypass via 0.0.0.0 (high 7.1)
- [CVE-2026-25591](https://insights.sbomify.com/CVE-2026-25591/): New API has an SQL LIKE Wildcard Injection DoS via Token Search (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41432 and fix it if it is affected.

What it is: CVE-2026-41432 is a high-severity authentication bypass vulnerability in QuantumNous new-api, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41432 exists.

Affected packages and fixed versions:
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 0.12.10
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 0.12.10
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 0.12.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41432/ (Markdown: https://insights.sbomify.com/CVE-2026-41432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41432
- OSV: https://osv.dev/vulnerability/CVE-2026-41432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41432/
Summaries are generated and may contain mistakes; the official description above is the record.
