# CVE-2026-41479: Authlib OAuth 2.0 has Open Redirect in Authorization API that allows attacker-controlled redirect_uri through unsupported response_type


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-41479, ECHO-c358-1d0d-d3a2, GHSA-w8p2-r796-3vmq, MINI-p297-6w5v-99r9, MINI-v75p-c3rc-gqf7, PYSEC-2026-2119, ROOT-APP-PYPI-CVE-2026-41479, SUSE-SU-2026:4111-1, UBUNTU-CVE-2026-41479, openSUSE-SU-2026:21795-1

## What is CVE-2026-41479?

CVE-2026-41479 is a medium-severity vulnerability in authlib, published on 22 Jun 2026. 

### Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.6.10 and 1.7.1, Authlib's OAuth 2.0 authorization endpoint can be turned into an unauthenticated open redirect when a request uses an unsupported response_type and supplies an attacker-controlled redirect_uri. The vulnerable behavior happens before client lookup and before any redirect URI validation. As a result, an attacker does not need a valid client registration, an authenticated user, or any prior state. A single request to the authorization endpoint is enough to obtain a 302 Location response to an arbitrary attacker-controlled URL. This vulnerability is fixed in 1.6.10 and 1.7.1.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-41479?

5 open source packages ship an affected version, including authlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.6.10 |
| `authlib` | PyPI | All versions | 1.6.10 |
| `authlib` | PyPI | All versions | 1.6.10 |
| `authlib` | PyPI | From 1.7.0 | 1.7.1 |
| `authlib` | PyPI | From 1.7.0 | 1.7.1 |
| `python-Authlib` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 1.3.1-150600.3.30.1 |
| `python-Authlib` | openSUSE:Leap 16.0 | All versions | 1.5.2-bp160.4.1 |

Products: Authlib Authlib.

## How do I fix CVE-2026-41479?

Upgrade authlib to a fixed version for your release line: 1.6.10 or 1.7.1.

## Is CVE-2026-41479 being exploited?

There is no known exploitation of CVE-2026-41479 in the wild and no public exploit code.

## Other vulnerabilities in authlib

- [CVE-2026-27962](https://insights.sbomify.com/CVE-2026-27962/): Authlib JWS JWK Header Injection: Signature Verification Bypass (critical 9.1)
- [CVE-2026-28490](https://insights.sbomify.com/CVE-2026-28490/): Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle (high 8.3)
- [CVE-2026-28498](https://insights.sbomify.com/CVE-2026-28498/): Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding (high 8.2)
- [CVE-2026-28802](https://insights.sbomify.com/CVE-2026-28802/): Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification (high 7.7)
- [CVE-2025-61920](https://insights.sbomify.com/CVE-2025-61920/): Authlib is vulnerable to Denial of Service via Oversized JOSE Segments (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41479 and fix it if it is affected.

What it is: CVE-2026-41479 is a medium-severity vulnerability in authlib, published on 22 Jun 2026. 
Exploitation: There is no known exploitation of CVE-2026-41479 in the wild and no public exploit code.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.6.10
- authlib (PyPI): affected all versions; fixed in 1.6.10
- authlib (PyPI): affected all versions; fixed in 1.6.10
- authlib (PyPI): affected from 1.7.0; fixed in 1.7.1
- authlib (PyPI): affected from 1.7.0; fixed in 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41479/ (Markdown: https://insights.sbomify.com/CVE-2026-41479/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41479
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41479
- OSV: https://osv.dev/vulnerability/CVE-2026-41479

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41479/
Summaries are generated and may contain mistakes; the official description above is the record.
