CVE-2026-41485 Kyverno Controller Denial of Service via forEach Mutation Panic
A user with policy creation permissions can crash the Kyverno controller via a type assertion panic, causing a persistent denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41485?
CVE-2026-41485 is a high-severity denial of service vulnerability in kyverno, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kyverno is a policy engine designed for cloud native platform engineering teams. Prior to versions 1.17.2 and 1.16.4, an unchecked type assertion in the `forEach` mutation handler allows any user with permission to create a `Policy` or `ClusterPolicy` to crash the cluster-wide background controller into a persistent CrashLoopBackOff. The same bug also causes the admission controller to drop connections and block all matching resource operations. The crash loop persists until the policy is deleted. The vulnerability is confined to the legacy engine, and CEL-based policies are unaffected. Versions 1.17.2 and 1.16.4 fix the issue.
Weakness: CWE-617
Which versions are affected by CVE-2026-41485?
6 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/kyverno/kyverno Go | From 1.13.0 | 1.16.4, 1.17.2 |
github.com/kyverno/kyverno Go | From 1.13.0 | 1.16.4 |
github.com/kyverno/kyverno Go | From 1.13.0 | 1.16.4 |
github.com/kyverno/kyverno Go | From 1.17.0-rc.1 | 1.17.2 |
github.com/kyverno/kyverno Go | From 1.17.0-rc.1 | 1.17.2 |
kyverno Bitnami | All versions | 1.16.4, 1.17.2 |
Products include Kyverno Kyverno.
How do I fix CVE-2026-41485?
Upgrade github.com/kyverno/kyverno to a fixed version for your release line: 1.16.4 or 1.17.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-41485 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41485 exists.
Other vulnerabilities in kyverno
- CVE-2026-22039 Kyverno Cross-Namespace Privilege Escalation via Policy apiCall
- CVE-2026-4789 CVE-2026-4789
- CVE-2025-46342 Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements
- CVE-2026-41323 Kyverno: ServiceAccount token leaked to external servers via apiCall service URL
- CVE-2026-40868 kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token
Sources
Also known as BIT-kyverno-2026-41485, ECHO-12c1-8179-4525, GHSA-fpjq-c37h-cqcv, GO-2026-5374, MINI-67v6-5g95-86fx, MINI-7w84-vc66-qf4x and 11 more.