# CVE-2026-41485: Kyverno Controller Denial of Service via forEach Mutation Panic

> A user with policy creation permissions can crash the Kyverno controller via a type assertion panic, causing a persistent denial of service.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** BIT-kyverno-2026-41485, ECHO-12c1-8179-4525, GHSA-fpjq-c37h-cqcv, GO-2026-5374, MINI-67v6-5g95-86fx, MINI-7w84-vc66-qf4x, MINI-96g6-rqj4-prpr, MINI-fcpv-pq26-g59r, MINI-g26q-hf86-gv3x, MINI-g64x-f39w-2x3p, MINI-g932-h364-jw74, MINI-gq76-4v74-cgqj, MINI-h633-28gc-9qh5, MINI-hm38-679p-8v4p, MINI-mprf-8jxx-79r6, MINI-p7rq-fp66-6cvf, MINI-r8c2-2r3p-gcq7

## What is CVE-2026-41485?

CVE-2026-41485 is a high-severity denial of service vulnerability in kyverno, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kyverno is a policy engine designed for cloud native platform engineering teams. Prior to versions 1.17.2 and 1.16.4, an unchecked type assertion in the `forEach` mutation handler allows any user with permission to create a `Policy` or `ClusterPolicy` to crash the cluster-wide background controller into a persistent CrashLoopBackOff. The same bug also causes the admission controller to drop connections and block all matching resource operations. The crash loop persists until the policy is deleted. The vulnerability is confined to the legacy engine, and CEL-based policies are unaffected. Versions 1.17.2 and 1.16.4 fix the issue.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2026-41485?

6 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | From 1.13.0 | 1.16.4, 1.17.2 |
| `github.com/kyverno/kyverno` | Go | From 1.13.0 | 1.16.4 |
| `github.com/kyverno/kyverno` | Go | From 1.13.0 | 1.16.4 |
| `github.com/kyverno/kyverno` | Go | From 1.17.0-rc.1 | 1.17.2 |
| `github.com/kyverno/kyverno` | Go | From 1.17.0-rc.1 | 1.17.2 |
| `kyverno` | Bitnami | All versions | 1.16.4, 1.17.2 |

Products: Kyverno Kyverno.

## How do I fix CVE-2026-41485?

Upgrade github.com/kyverno/kyverno to a fixed version for your release line: 1.16.4 or 1.17.2.

## Is CVE-2026-41485 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41485 exists.

## Other vulnerabilities in kyverno

- [CVE-2026-22039](https://insights.sbomify.com/CVE-2026-22039/): Kyverno Cross-Namespace Privilege Escalation via Policy apiCall (critical 10.0)
- [CVE-2026-4789](https://insights.sbomify.com/CVE-2026-4789/): CVE-2026-4789 (critical 9.8)
- [CVE-2025-46342](https://insights.sbomify.com/CVE-2025-46342/): Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements (high 8.6)
- [CVE-2026-41323](https://insights.sbomify.com/CVE-2026-41323/): Kyverno: ServiceAccount token leaked to external servers via apiCall service URL (high 8.1)
- [CVE-2026-40868](https://insights.sbomify.com/CVE-2026-40868/): kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41485 and fix it if it is affected.

What it is: CVE-2026-41485 is a high-severity denial of service vulnerability in kyverno, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41485 exists.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected from 1.13.0; fixed in 1.16.4, 1.17.2
- github.com/kyverno/kyverno (Go): affected from 1.13.0; fixed in 1.16.4
- github.com/kyverno/kyverno (Go): affected from 1.13.0; fixed in 1.16.4
- github.com/kyverno/kyverno (Go): affected from 1.17.0-rc.1; fixed in 1.17.2
- github.com/kyverno/kyverno (Go): affected from 1.17.0-rc.1; fixed in 1.17.2
- kyverno (Bitnami): affected all versions; fixed in 1.16.4, 1.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41485/ (Markdown: https://insights.sbomify.com/CVE-2026-41485/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41485
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41485
- OSV: https://osv.dev/vulnerability/CVE-2026-41485

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41485/
Summaries are generated and may contain mistakes; the official description above is the record.
