CVE-2026-41487 Missing authorization in langfuse

Medium 5.3 Published Updated

Low-privileged members can retrieve stored LLM API keys by manipulating connection settings, exposing sensitive credentials to attackers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-41487?

CVE-2026-41487 is a medium-severity missing authorization vulnerability in langfuse, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Langfuse is an open source large language model engineering platform. From version 3.68.0 to before version 3.167.0, there is a role-based-access control flaw in the LLM connection update flow. An authenticated, low-privileged user of role “member” in a project could request the update of an existing LLM connection to an attacker-controlled baseUrl, causing Langfuse to reuse the stored provider secret and redirect the test request to an attacker-controlled endpoint. This could expose the plaintext provider LLM API key for that connection. The attack is only possible if a user is already part of a project and has “member” scoped access. This issue has been patched in version 3.167.0.

Weakness: CWE-284

Which versions are affected by CVE-2026-41487?

It affects 1 product.

Products include Langfuse Langfuse.

How do I fix CVE-2026-41487?

No fix has been published for CVE-2026-41487 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-41487 being exploited?

There is no known exploitation of CVE-2026-41487 in the wild and no public exploit code.

Sources

Also known as GHSA-2524-j966-gfgh.

Is CVE-2026-41487 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free