{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-41487 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-41487 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-41487 is a medium-severity missing authorization vulnerability in langfuse, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41487 and fix it if it is affected.\n\nWhat it is: CVE-2026-41487 is a medium-severity missing authorization vulnerability in langfuse, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-41487 in the wild and no public exploit code.\n\nAffected product: langfuse. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41487/ (Markdown: https://insights.sbomify.com/CVE-2026-41487/index.md)","id":"CVE-2026-41487","markdown":"https://insights.sbomify.com/CVE-2026-41487/index.md","name":"CVE-2026-41487","record":{"aliases":["GHSA-2524-j966-gfgh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM engineering platform","requires_auth":"low_privilege","summary":"Low-privileged members can retrieve stored LLM API keys by manipulating connection settings, exposing sensitive credentials to attackers.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"langfuse","vendor":"langfuse"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Langfuse is an open source large language model engineering platform. From version 3.68.0 to before version 3.167.0, there is  a role-based-access control flaw in the LLM connection update flow. An authenticated, low-privileged user of role “member” in a project could request the update of an existing LLM connection to an attacker-controlled baseUrl, causing Langfuse to reuse the stored provider secret and redirect the test request to an attacker-controlled endpoint. This could expose the plaintext provider LLM API key for that connection. The attack is only possible if a user is already part of a project and has “member” scoped access. This issue has been patched in version 3.167.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Missing authorization in langfuse","id":"CVE-2026-41487","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":0,"n_references":6,"next":{"headline":"angchain-openai: Image token counting SSRF protection can be bypassed via DNS rebinding","id":"CVE-2026-41488"},"packages":[],"prev":{"headline":"Ray: Remote Code Execution via Parquet Arrow Extension Type Deserialization","id":"CVE-2026-41486"},"products":["langfuse"],"published":"2026-05-08","related":[{"cvss_score":7.6,"headline":"Missing authorization in n/a","id":"CVE-2025-59305","kev_date_added":null,"published":"2025-09-24"},{"cvss_score":6.5,"headline":"Langfuse SSO Account Takeover via CSRF or phishing attack","id":"CVE-2025-65107","kev_date_added":null,"published":"2025-11-21"},{"cvss_score":6.3,"headline":"Langfuse Slack OAuth Installation Endpoint Lacks Authentication, Enabling Arbitrary Project Linking","id":"CVE-2026-24055","kev_date_added":null,"published":"2026-01-22"},{"cvss_score":5,"headline":"Langfuse vulnerable to cross‑organization enumeration of member \u0026 invitation lists via project membership APIs","id":"CVE-2025-64504","kev_date_added":null,"published":"2025-11-10"},{"cvss_score":2.3,"headline":"Langfuse Webhook promptRouter.ts promptChangeEventSourcing server-side request forgery","id":"CVE-2025-9799","kev_date_added":null,"published":"2025-09-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-08","vendors":["langfuse"]},"summary":"Low-privileged members can retrieve stored LLM API keys by manipulating connection settings, exposing sensitive credentials to attackers.","url":"https://insights.sbomify.com/CVE-2026-41487/"}