# CVE-2026-41490: Dagster Vulnerable to SQL Injection via Dynamic Partition Keys in Database I/O Manager Integrations

> Attackers with dynamic partition permissions can inject SQL into Dagster database integrations, enabling arbitrary code execution and data manipulation.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-mjw2-v2hm-wj34, PYSEC-2026-2432, PYSEC-2026-2433, PYSEC-2026-2434, PYSEC-2026-2435, PYSEC-2026-2436, PYSEC-2026-2437

## What is CVE-2026-41490?

CVE-2026-41490 is a high-severity SQL injection vulnerability in dagster-io dagster, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Dagster is an orchestration platform for the development, production, and observation of data assets. Prior to Dagster Core version 1.13.1 and prior to Dagster libraries version 0.29.1, the DuckDB, Snowflake, BigQuery, and DeltaLake I/O managers constructed SQL WHERE clauses by interpolating dynamic partition key values into queries without escaping. A user with the Add Dynamic Partitions permission could create a partition key that injects arbitrary SQL, which would execute against the target database backend under the I/O manager's credentials. Only deployments that use dynamic partitions are affected. Pipelines using static or time-window partitions are not impacted. This issue has been patched in Dagster Core version 1.13.1 and Dagster libraries version 0.29.1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-41490?

18 open source packages ship an affected version, including dagster, dagster-deltalake and dagster-duckdb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dagster` | PyPI | All versions | 1.13.1 |
| `dagster` | PyPI | All versions | 1.13.1 |
| `dagster` | PyPI | All versions | 1.13.1 |
| `dagster-deltalake` | PyPI | All versions | 0.29.1 |
| `dagster-deltalake` | PyPI | All versions | 0.29.1 |
| `dagster-deltalake` | PyPI | All versions | 0.29.1 |
| `dagster-duckdb` | PyPI | All versions | 0.29.1 |
| `dagster-duckdb` | PyPI | All versions | 0.29.1 |
| `dagster-duckdb` | PyPI | All versions | 0.29.1 |
| `dagster-gcp` | PyPI | All versions | 0.29.1 |
| `dagster-gcp` | PyPI | All versions | 0.29.1 |
| `dagster-gcp` | PyPI | All versions | 0.29.1 |
| `dagster-snowflake` | PyPI | All versions | 0.29.1 |
| `dagster-snowflake` | PyPI | All versions | 0.29.1 |
| `dagster-snowflake` | PyPI | All versions | 0.29.1 |
| `dagster-snowflake-polars` | PyPI | All versions | 0.29.1 |
| `dagster-snowflake-polars` | PyPI | All versions | 0.29.1 |
| `dagster-snowflake-polars` | PyPI | All versions | 0.29.1 |

## How do I fix CVE-2026-41490?

Upgrade dagster to 1.13.1 or later.

## Is CVE-2026-41490 being exploited?

There is no known exploitation of CVE-2026-41490 in the wild and no public exploit code.

Public exploit code:

- SQL injection in Dagster database I/O managers via dynamic partition keys — CVE-2026-41490 / CVSS 8.3 (github_poc): https://github.com/romain-deperne/CVE-2026-41490

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41490 and fix it if it is affected.

What it is: CVE-2026-41490 is a high-severity SQL injection vulnerability in dagster-io dagster, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41490 in the wild and no public exploit code.

Affected packages and fixed versions:
- dagster (PyPI): affected all versions; fixed in 1.13.1
- dagster (PyPI): affected all versions; fixed in 1.13.1
- dagster (PyPI): affected all versions; fixed in 1.13.1
- dagster-deltalake (PyPI): affected all versions; fixed in 0.29.1
- dagster-deltalake (PyPI): affected all versions; fixed in 0.29.1
- dagster-deltalake (PyPI): affected all versions; fixed in 0.29.1
- dagster-duckdb (PyPI): affected all versions; fixed in 0.29.1
- dagster-duckdb (PyPI): affected all versions; fixed in 0.29.1
- dagster-duckdb (PyPI): affected all versions; fixed in 0.29.1
- dagster-gcp (PyPI): affected all versions; fixed in 0.29.1
- dagster-gcp (PyPI): affected all versions; fixed in 0.29.1
- dagster-gcp (PyPI): affected all versions; fixed in 0.29.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41490/ (Markdown: https://insights.sbomify.com/CVE-2026-41490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41490
- OSV: https://osv.dev/vulnerability/CVE-2026-41490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41490/
Summaries are generated and may contain mistakes; the official description above is the record.
