# CVE-2026-41493: yard: Possible arbitrary path traversal and file access via yard server

> Attackers can access arbitrary files on the host machine when using the YARD server to serve documentation.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** DEBIAN-CVE-2026-41493, GHSA-3jfp-46x4-xgfj, OESA-2026-2205, OESA-2026-2206, OESA-2026-2207, OESA-2026-2208, OESA-2026-2285, UBUNTU-CVE-2026-41493

## What is CVE-2026-41493?

CVE-2026-41493 is a medium-severity path traversal vulnerability in lsegal yard, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

YARD is a Ruby Documentation tool. Prior to version 0.9.42, a path traversal vulnerability was discovered in YARD when using yard server to serve documentation. This bug would allow unsanitized HTTP requests to access arbitrary files on the machine of a yard server host under certain conditions. This issue has been patched in version 0.9.42.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-41493?

2 open source packages ship an affected version, including yard. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yard` | RubyGems | All versions | 0.9.42 |
| `yard` | RubyGems | All versions | 0.9.42 |

Products: Yardoc Yard.

## How do I fix CVE-2026-41493?

Upgrade yard to 0.9.42 or later.

## Is CVE-2026-41493 being exploited?

There is no known exploitation of CVE-2026-41493 in the wild and no public exploit code.

## Other vulnerabilities in lsegal yard

- [CVE-2019-1020001](https://insights.sbomify.com/CVE-2019-1020001/): Path Traversal vulnerability that affects yard (high 7.5)
- [CVE-2017-17042](https://insights.sbomify.com/CVE-2017-17042/): Arbitrary file read vulnerability in yard server (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41493 and fix it if it is affected.

What it is: CVE-2026-41493 is a medium-severity path traversal vulnerability in lsegal yard, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41493 in the wild and no public exploit code.

Affected packages and fixed versions:
- yard (RubyGems): affected all versions; fixed in 0.9.42
- yard (RubyGems): affected all versions; fixed in 0.9.42

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41493/ (Markdown: https://insights.sbomify.com/CVE-2026-41493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41493
- OSV: https://osv.dev/vulnerability/CVE-2026-41493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41493/
Summaries are generated and may contain mistakes; the official description above is the record.
