# CVE-2026-41496: PraisonAI: SQL Injection via unvalidated `table_prefix` in 9 conversation store backends (incomplete fix for CVE-2026-40315)

> Attackers can execute arbitrary SQL commands via unvalidated table prefixes in multiple database backends, potentially reading or modifying data.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-rg3h-x3jw-7jm5, PYSEC-2026-2923, PYSEC-2026-2952

## What is CVE-2026-41496?

CVE-2026-41496 is a high-severity SQL injection vulnerability in MervinPraison PraisonAI, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to praisonai version 4.6.9 and praisonaiagents version 1.6.9, the fix for CVE-2026-40315 added input validation to SQLiteConversationStore only. Nine sibling backends — MySQL, PostgreSQL, async SQLite/MySQL/PostgreSQL, Turso, SingleStore, Supabase, SurrealDB — pass table_prefix straight into f-string SQL. Same root cause, same code pattern, same exploitation. 52 unvalidated injection points across the codebase. postgres.py additionally accepts an unvalidated schema parameter used directly in DDL. This issue has been patched in praisonai version 4.6.9 and praisonaiagents version 1.6.9.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-41496?

6 open source packages ship an affected version, including praisonai and praisonaiagents. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.5.149 |
| `praisonai` | PyPI | All versions | 4.5.149 |
| `praisonai` | PyPI | All versions | 4.5.149 |
| `praisonaiagents` | PyPI | All versions | 1.6.8 |
| `praisonaiagents` | PyPI | All versions | 1.6.8 |
| `praisonaiagents` | PyPI | All versions | 1.6.8 |

Products: Praison Praisonai, Praison Praisonaiagents.

## How do I fix CVE-2026-41496?

Upgrade praisonai to 4.5.149 or later.

## Is CVE-2026-41496 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41496 exists.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41496 and fix it if it is affected.

What it is: CVE-2026-41496 is a high-severity SQL injection vulnerability in MervinPraison PraisonAI, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41496 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.5.149
- praisonai (PyPI): affected all versions; fixed in 4.5.149
- praisonai (PyPI): affected all versions; fixed in 4.5.149
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.8
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.8
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41496/ (Markdown: https://insights.sbomify.com/CVE-2026-41496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41496
- OSV: https://osv.dev/vulnerability/CVE-2026-41496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41496/
Summaries are generated and may contain mistakes; the official description above is the record.
