# CVE-2026-41501: electerm has Command Injection Vulnerability via runLinux function


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-8x35-hph8-37hq

## What is CVE-2026-41501?

CVE-2026-41501 is a critical vulnerability in electerm, published on 8 May 2026. 

### Official description

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec("rm -rf ...") command without validation. This issue has been patched in version 3.3.8.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-41501?

2 open source packages ship an affected version, including electerm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electerm` | npm | All versions | 3.3.8 |
| `electerm` | npm | All versions | 3.3.8 |

Products: Electerm Project Electerm.

## How do I fix CVE-2026-41501?

Upgrade electerm to 3.3.8 or later.

## Is CVE-2026-41501 being exploited?

There is no known exploitation of CVE-2026-41501 in the wild and no public exploit code.

## Other vulnerabilities in electerm

- [CVE-2026-41500](https://insights.sbomify.com/CVE-2026-41500/): electerm has Command Injection Vulnerability via runMac function (critical 9.8)
- [CVE-2020-23256](https://insights.sbomify.com/CVE-2020-23256/): electerm allows unauthorized users to execute arbitrary commands (critical 9.8)
- [CVE-2026-43941](https://insights.sbomify.com/CVE-2026-43941/): Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click (critical 9.6)
- [CVE-2026-43944](https://insights.sbomify.com/CVE-2026-43944/): electerm: dangerous code can be run through links or command line (critical 9.4)
- [CVE-2026-45353](https://insights.sbomify.com/CVE-2026-45353/): electerm: Local code through electerm's single-instance socket (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41501 and fix it if it is affected.

What it is: CVE-2026-41501 is a critical vulnerability in electerm, published on 8 May 2026. 
Exploitation: There is no known exploitation of CVE-2026-41501 in the wild and no public exploit code.

Affected packages and fixed versions:
- electerm (npm): affected all versions; fixed in 3.3.8
- electerm (npm): affected all versions; fixed in 3.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41501/ (Markdown: https://insights.sbomify.com/CVE-2026-41501/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41501
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41501
- OSV: https://osv.dev/vulnerability/CVE-2026-41501

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41501/
Summaries are generated and may contain mistakes; the official description above is the record.
