CVE-2026-41510 OWASP Coraza WAF: Silent argument drop at ArgumentLimit allows bypass of ARGS-targeted rules via parameter flooding

High 7.2 Published Updated

Attackers can bypass WAF rules by flooding arguments, causing silent drops, and trigger denial of service via excessive memory consumption.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-41510?

CVE-2026-41510 is a high-severity vulnerability in corazawaf coraza, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OWASP Coraza WAF is a golang modsecurity compatible web application firewall library. From 3.0.0 until 3.8.1, Coraza silently drops arguments after SecArgumentsLimit in internal/corazawaf/transaction.go, while internal/bodyprocessors/urlencoded.go writes ARGS_POST without enforcing the cap. The flaw is triggered when an unauthenticated attacker sends more arguments than SecArgumentsLimit or supplies bodies that expand beyond the configured argument and flattening budgets. An unauthenticated attacker can flood requests with arguments so excess values are silently omitted from ARGS, ARGS_GET, ARGS_NAMES, ARGS_GET_NAMES, ARGS_POST, or ARGS_PATH before security rules inspect them; affected urlencoded and JSON processing can also consume excessive memory. The omission can bypass WAF rules protecting the downstream application, and unbounded or amplified argument processing can cause memory consumption and service degradation. This issue is fixed in version 3.8.1.

Weakness: CWE-770, CWE-693

Which versions are affected by CVE-2026-41510?

5 open source packages ship an affected version, including github.com/corazawaf/coraza/v3, github.com/corazawaf/coraza and github.com/corazawaf/coraza/v2.

PackageAffectedFixed in
github.com/corazawaf/coraza/v3 GoFrom 3.0.03.8.1
github.com/corazawaf/coraza/v3 GoFrom 3.0.03.8.1
github.com/corazawaf/coraza/v3 GoFrom 3.0.03.8.1
github.com/corazawaf/coraza GoAll versionsNone
github.com/corazawaf/coraza/v2 GoAll versionsNone

How do I fix CVE-2026-41510?

Upgrade github.com/corazawaf/coraza/v3 to 3.8.1 or later.

Is CVE-2026-41510 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41510 exists.

Sources

Also known as GHSA-6r3q-mjv7-xr8m, GO-2026-6668.

Is CVE-2026-41510 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free